Imported Upstream version 17.23.0
[platform/upstream/libzypp.git] / tests / repo / CMakeLists.txt
index 5110460..69f5011 100644 (file)
@@ -7,9 +7,14 @@ INCLUDE_DIRECTORIES( ${LIBZYPP_SOURCE_DIR}/tests/zypp )
 ADD_TESTS(
   DUdata
   ExtendedMetadata
-  MirrorList
   PluginServices
   RepoLicense
   RepoSigcheck
   RepoVariables
 )
+
+IF( NOT DISABLE_MEDIABACKEND_TESTS )
+ADD_TESTS(
+  MirrorList
+)
+ENDIF()