Imported Upstream version 2.9.1
[platform/upstream/libxml2.git] / python / tests / Makefile.am
index 52c89fc..95ebead 100644 (file)
@@ -19,6 +19,7 @@ PYTESTS=      \
     xpath.py   \
     outbuf.py  \
     inbuf.py   \
+    input_callback.py \
     resolver.py \
     regexp.py  \
     reader.py  \
@@ -55,8 +56,11 @@ XMLS=                \
     invalid.xml        \
     test.dtd
 
+CLEANFILES = core tmp.xml *.pyc
+
 if WITH_PYTHON
 tests: $(PYTESTS)
+       @for f in $(XMLS) ; do test -f $$f || $(LN_S) $(srcdir)/$$f . ; done
        @echo "## running Python regression tests"
        -@(PYTHONPATH="..:../.libs:$(srcdir)/..:$$PYTHONPATH" ; \
           export PYTHONPATH; \
@@ -69,6 +73,3 @@ tests: $(PYTESTS)
 else
 tests:
 endif
-
-clean:
-       rm -f *.pyc core