Bump to libxml2 2.9.4
[platform/upstream/libxml2.git] / packaging / libxml2.spec
index 8cfa4b7..f754794 100644 (file)
@@ -1,5 +1,12 @@
+%define run_tests 0
+%if %{run_tests}
+    # check is defined off at .rpmmacros file.
+    %define check %%check
+%endif
+
+
 Name:           libxml2
-Version:        2.9.1
+Version:        2.9.4
 Release:        0
 Summary:        A Library to Manipulate XML Files
 License:        MIT
@@ -73,11 +80,11 @@ cp %{SOURCE1001} .
 make %{?_smp_mflags} BASE_DIR="%_docdir" DOC_MODULE="%name"
 
 %check
-# qemu-arm can't keep up atm, disabling check for arm
-%ifnarch %arm
-make check
+%if %{run_tests}
+    %__make runtests || exit 0
 %endif
 
+
 %install
 make install DESTDIR="%buildroot" BASE_DIR="%_docdir" DOC_MODULE="%name"
 ln -s libxml2/libxml %{buildroot}%{_includedir}/libxml
@@ -113,5 +120,6 @@ ln -s libxml2/libxml %{buildroot}%{_includedir}/libxml
 %{_libdir}/libxml2.la
 %{_libdir}/*.sh
 %{_libdir}/pkgconfig/*.pc
+%{_libdir}/cmake/libxml2/libxml2-config.cmake
 
 %changelog