rolled back to 2.9.2 because 2.9.4 doesn't work with XML validator
[platform/upstream/libxml2.git] / packaging / libxml2.spec
index f754794..4ada015 100644 (file)
@@ -1,12 +1,5 @@
-%define run_tests 0
-%if %{run_tests}
-    # check is defined off at .rpmmacros file.
-    %define check %%check
-%endif
-
-
 Name:           libxml2
-Version:        2.9.4
+Version:        2.9.2
 Release:        0
 Summary:        A Library to Manipulate XML Files
 License:        MIT
@@ -64,6 +57,7 @@ to develop applications that require these.
 cp %{SOURCE1001} .
 
 %build
+touch configure.ac aclocal.m4 configure Makefile.am Makefile.in
 %configure --disable-static \
     --docdir=%_docdir/%name \
     --with-html-dir=%_docdir/%name/html \
@@ -80,11 +74,11 @@ cp %{SOURCE1001} .
 make %{?_smp_mflags} BASE_DIR="%_docdir" DOC_MODULE="%name"
 
 %check
-%if %{run_tests}
-    %__make runtests || exit 0
+# qemu-arm can't keep up atm, disabling check for arm
+%ifnarch %arm
+make check
 %endif
 
-
 %install
 make install DESTDIR="%buildroot" BASE_DIR="%_docdir" DOC_MODULE="%name"
 ln -s libxml2/libxml %{buildroot}%{_includedir}/libxml