Messages: merge macros with and without message code
[platform/upstream/libxkbcommon.git] / src / xkbcomp / keycodes.c
2023-09-24 Pierre Le MarreMessages: merge macros with and without message code
2023-09-24 Pierre Le MarreMessages: add new messages to registry
2023-09-19 Pierre Le MarreStructured log messages with a message registry
2019-12-27 Ran Benitaxkbcomp: make a couple of casts explicit to mark them...
2019-12-27 Ran Benitabuild: include config.h manually
2018-08-01 Ran BenitaMerge pull request #66 from whot/master
2018-08-01 Peter Huttererkeycodes: don't try to copy zero key aliases
2014-10-23 Ran Benitakeycodes: use correct printf format
2014-10-18 Ran Benitaxkbcomp: remove file->topName
2014-09-10 Ran Benitakeycodes: fix keymap compilation with no aliases and...
2014-07-25 Ran Benitakeycodes: split CopyKeyInfoToKeymap to several functions
2014-04-24 Ran Benitakeycodes: fix uninitialized variable
2014-04-22 Ran Benitakeymap, keycodes, compat: don't use darray for LEDs
2014-02-22 Ran Benitasymbols, keycodes: fix int return type when bool is...
2014-02-09 Ran Benitadoc: move some file comments into txt files in doc/
2013-08-02 Ran Benitaxkbcomp: handle empty keymaps
2013-07-18 Ran Benitaxkbcomp: escape the section names before storing them...
2013-03-18 Ran BenitaFix pointer style nit
2013-03-18 Ran Benitakeycodes: remove KeyNamesInfo::merge
2013-03-18 Ran Benitakeycodes: unwrap KeyNameInfo
2013-03-18 Ran Benitakeycodes: remove file_id
2013-03-18 Ran Benitakeymap: don't use darray for key aliases
2013-03-18 Ran Benitakeycodes: don't do unnecessary copies while merging
2013-03-18 Ran BenitaMove a couple of general keymap functions from keycodes.c
2013-03-18 Ran Benitakeycodes: remove unneeded alias conflict check
2013-03-18 Ran Benitaxkbcomp: handle XKB file include's better
2013-03-18 Ran BenitaMore spelling errors
2013-03-18 Ran Benitakeycodes: fix spelling in error message
2013-03-18 Ran BenitaFix dead assignments
2013-03-18 Ran Benitakeycodes: some minor style
2013-03-18 Ran BenitaChange 'indicator' to 'led' everywhere possible
2012-10-21 Ran BenitaSilence a couple of warnings
2012-10-11 Ran Benitacompat: add documentation for interpret's
2012-10-10 Ran BenitaRemove the XKB_NUM_INDICATORS limit
2012-10-10 Ran Benitakeymap: don't use darray for keymap->keys
2012-10-10 Ran Benitakeycodes: refactor AddIndicatorName
2012-10-06 Ran BenitaOmit struct '_Name' from non-recursive struct typedefs
2012-09-27 Ran BenitaFix type of keycode in parser and ast
2012-09-27 Ran BenitaDon't limit key names to 4 characters
2012-09-23 Ran BenitaAPI: add _context prefix to log-related functions
2012-09-23 Daniel StonePromote keymap enumeration API to public
2012-09-15 Ran Benitakeycodes: add KeyNameInfo
2012-09-14 Ran Benitakeycodes: rename computedMin/Max to min/max_key_code
2012-09-14 Ran Benitakeycodes: ignore explicit minimum/maximum statements
2012-09-14 Ran Benitastate, map: constify references to xkb_key
2012-09-14 Ran BenitaClean up Init/Clear functions
2012-09-13 Ran Benitasymbols: remove unneeded recursion form CopySymbolsDef
2012-09-10 Daniel Stonekbproto unentanglement: XkbNumIndicators
2012-09-10 Daniel Stonekbproto untanglement: XkbKeyNameLength
2012-09-04 Ran BenitaFold keymap->indicator_names into keymap->indicators
2012-09-03 Ran BenitaConvert rest of names in xkb_keymap back to atoms
2012-09-03 Ran Benitaexpr: make ResolveString return an atom
2012-09-03 Ran Benitalog: replace "priority" by "level" everywhere
2012-09-02 Ran Benitakeycodes: remove outdated comments
2012-09-02 Ran Benitakeycodes: use darray for aliases instead of list
2012-09-02 Ran Benitakeycodes: use array for indicator names instead of...
2012-09-02 Ran Benitakeycodes: ignore "virtual" in indicators
2012-09-02 Ran Benitaexpr: move op_type/value_type_to_string functions to ast
2012-09-02 Ran Benitaxkbcomp: seperate keymap-copying code from Compile...
2012-09-01 Ran Benitatypes: add "Effects on keymap" to overview
2012-09-01 Ran BenitaOrganize xkbcomp/ header files
2012-08-10 Ran Benitakeycodes: save context in Info, not keymap
2012-08-10 Ran BenitaRemove xkbcomp/misc.c
2012-08-10 Ran BenitaRemove AutoKeyNames feature
2012-08-07 Ran Benitakeycodes: small changes
2012-08-07 Ran BenitaHandle key names consistently
2012-08-07 Ran Benitakeycodes: add a general overview
2012-08-07 Ran BenitaMake top level Handle*File functions nicer
2012-08-07 Ran BenitaUse xkb_led_index_t throughout
2012-07-26 Ran Benitaexpr: drop ExprResult from ResolveKeyCode
2012-07-26 Ran Benitaexpr: drop ExprResult from ResolveString
2012-07-26 Ran Benitaexpr: drop ExprResult from ResolveLhs
2012-07-26 Ran BenitaConvert defines to enums in xkbcomp.h
2012-07-26 Ran Benitautils: add/replace string equality macros
2012-07-26 Ran BenitaDrop Xkbc prefix of text functions
2012-07-26 Ran BenitaSome atom related optimizations
2012-07-26 Ran Benitakeycodes: fix valgrind warnings
2012-07-22 Ran Benitaxkbcomp: use new log functions
2012-07-22 Ran Benitakeycodes: use new log functions
2012-07-22 Ran Benitakeycodes: add keymap to KeyNamesInfo
2012-07-18 Ran BenitaSimplify HandleInclude functions
2012-07-18 Ran BenitaRemove haveSelf include feature
2012-07-18 Ran BenitaConvert macros to inline functions
2012-07-18 Ran Benitakeycodes: use list instead of CommonInfo in IndicatorNa...
2012-07-18 Ran Benitakeycodes: use list instead of CommonInfo in AliasInfo
2012-07-18 Ran BenitaMove alias.c functions into keycodes.c
2012-07-18 Ran BenitaGet rid of struct xkb_key_name
2012-07-18 Ran BenitaAdd common xkb_key struct
2012-07-18 Ran BenitaReplace xkb_keycode_t 'key' variable name by 'kc'
2012-07-18 Ran BenitaGet rid of xkb_key_names
2012-07-18 Ran BenitaGet rid of xkb_indicator
2012-07-17 Daniel StoneRun source tree through uncrustify
2012-07-14 Ran BenitaConvert missed enum merge_mode variables
2012-07-14 Ran BenitaFix fileID mess
2012-07-13 Ran BenitaRemove MERGE_ALT_FORM merge mode
2012-07-12 Ran Benitadump: add back kccgst names
2012-06-30 Ran BenitaUse enum for merge mode
2012-06-30 Ran BenitaUse enum for file types
2012-06-26 Ran BenitaUse void* instead of old style char* in CommonInfo...
2012-06-09 Ran Benitadarray: some changes for convenience
next