ipptest: add fimc and rotator test applications
[platform/upstream/libdrm.git] / tests / Makefile.am
index 3e74705..895e8e8 100644 (file)
@@ -6,22 +6,29 @@ AM_CPPFLAGS = \
 
 LDADD = $(top_builddir)/libdrm.la
 
-noinst_PROGRAMS = \
+check_PROGRAMS = \
        dristat \
        drmstat
 
-SUBDIRS =
+SUBDIRS = modeprint
 
 if HAVE_LIBKMS
-SUBDIRS += kmstest
+SUBDIRS += kmstest modetest
 endif
 
-if HAVE_INTEL
+if HAVE_RADEON
+SUBDIRS += radeon
+endif
+
+if HAVE_EXYNOS
+SUBDIRS += exynos
+SUBDIRS += ipptest
+SUBDIRS += rottest
 endif
 
 if HAVE_LIBUDEV
 
-EXTRA_LTLIBRARIES = libdrmtest.la
+check_LTLIBRARIES = libdrmtest.la
 
 libdrmtest_la_SOURCES = \
        drmtest.c \
@@ -47,12 +54,9 @@ TESTS =                                              \
        name_from_fd                            \
        $(NULL)
 
-if HAVE_INTEL
-SUBDIRS += \
-       modeprint                               \
-       modetest                                \
-       $(NULL)
+SUBDIRS += vbltest $(NULL)
 
+if HAVE_INTEL
 TESTS +=                                       \
        gem_basic                               \
        gem_flink                               \
@@ -61,8 +65,6 @@ TESTS +=                                      \
        $(NULL)
 endif
 
-EXTRA_PROGRAMS = $(TESTS)
+check_PROGRAMS += $(TESTS)
 
 endif
-
-CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES)