ipptest: add fimc and rotator test applications
[platform/upstream/libdrm.git] / tests / Makefile.am
index 01ca8b4..895e8e8 100644 (file)
@@ -10,10 +10,20 @@ check_PROGRAMS = \
        dristat \
        drmstat
 
-SUBDIRS =
+SUBDIRS = modeprint
 
 if HAVE_LIBKMS
-SUBDIRS += kmstest
+SUBDIRS += kmstest modetest
+endif
+
+if HAVE_RADEON
+SUBDIRS += radeon
+endif
+
+if HAVE_EXYNOS
+SUBDIRS += exynos
+SUBDIRS += ipptest
+SUBDIRS += rottest
 endif
 
 if HAVE_LIBUDEV
@@ -47,15 +57,6 @@ TESTS =                                              \
 SUBDIRS += vbltest $(NULL)
 
 if HAVE_INTEL
-if HAVE_LIBKMS
-SUBDIRS += \
-       modetest
-endif
-
-SUBDIRS += \
-       modeprint                               \
-       $(NULL)
-
 TESTS +=                                       \
        gem_basic                               \
        gem_flink                               \