Imported Upstream version 1.0.0
[platform/upstream/iotivity.git] / extlibs / tinydtls / configure.in
index 70b9a54..b341497 100644 (file)
@@ -69,6 +69,18 @@ AC_ARG_WITH(psk,
   [AC_DEFINE(DTLS_PSK, 1, [Define to 1 if building with PSK support])
    DTLS_PSK=1])
 
+AC_ARG_WITH(x509,
+  [AS_HELP_STRING([--with-x509],[use dtls as transport protocol])],
+  [AC_DEFINE(DTLS_X509, 1, [Define to 1 if building with X.509 support])
+   DTLS_X509=1],
+  [])
+
+AC_ARG_WITH(hal,
+  [AS_HELP_STRING([--with-hal],[use a hardware abstraction layer for crypto functions])],
+  [AC_DEFINE(DTLS_CRYPTO_HAL, 1, [Define to 1 if building with Hardware Abstraction Layer])
+   DTLS_CRYPTO_HAL=1],
+  [])
+
 CPPFLAGS="${CPPFLAGS} -DDTLSv12 -DWITH_SHA256"
 OPT_OBJS="${OPT_OBJS} sha2/sha2.o"