Imported Upstream version 8.2.2
[platform/upstream/harfbuzz.git] / util / meson.build
index fdab620..e857384 100644 (file)
@@ -6,6 +6,10 @@ hb_shape_sources = [
   'hb-shape.cc',
 ]
 
+hb_info_sources = [
+  'hb-info.cc',
+]
+
 hb_ot_shape_closure_sources = [
   'hb-ot-shape-closure.cc',
 ]
@@ -17,15 +21,15 @@ hb_subset_cli_sources = [
 util_deps = [freetype_dep, cairo_dep, cairo_ft_dep, glib_dep]
 
 if conf.get('HAVE_GLIB', 0) == 1
-  if conf.get('HAVE_FREETYPE', 0) == 1 and conf.get('HAVE_CAIRO_FT', 0) == 1
-
+  if conf.get('HAVE_CAIRO', 0) == 1
     hb_view = executable('hb-view', hb_view_sources,
       cpp_args: cpp_args,
       include_directories: [incconfig, incsrc],
       dependencies: [util_deps, chafa_dep],
-      link_with: [libharfbuzz],
+      link_with: [libharfbuzz, libharfbuzz_cairo],
       install: true,
     )
+    meson.override_find_program('hb-view', hb_view)
   endif
 
   hb_shape = executable('hb-shape', hb_shape_sources,
@@ -35,6 +39,16 @@ if conf.get('HAVE_GLIB', 0) == 1
     link_with: [libharfbuzz],
     install: true,
   )
+  meson.override_find_program('hb-shape', hb_shape)
+
+  hb_info = executable('hb-info', [hb_info_sources, gobject_enums_h],
+    cpp_args: cpp_args,
+    include_directories: [incconfig, incsrc],
+    dependencies: [util_deps, libharfbuzz_gobject_dep, chafa_dep],
+    link_with: [libharfbuzz],
+    install: true,
+  )
+  meson.override_find_program('hb-info', hb_info)
 
   hb_subset = executable('hb-subset', hb_subset_cli_sources,
     cpp_args: cpp_args,
@@ -43,6 +57,7 @@ if conf.get('HAVE_GLIB', 0) == 1
     link_with: [libharfbuzz, libharfbuzz_subset],
     install: true,
   )
+  meson.override_find_program('hb-subset', hb_subset)
 
   hb_ot_shape_closure = executable('hb-ot-shape-closure', hb_ot_shape_closure_sources,
     cpp_args: cpp_args,
@@ -51,6 +66,7 @@ if conf.get('HAVE_GLIB', 0) == 1
     link_with: [libharfbuzz],
     install: true,
   )
+  meson.override_find_program('hb-ot-shape-closure', hb_ot_shape_closure)
 else
   # Disable tests that use this
   hb_shape = disabler()