Imported Upstream version 1.2.7
[platform/upstream/harfbuzz.git] / util / Makefile.am
index 3f23bab..2543a60 100644 (file)
@@ -1,11 +1,12 @@
 # Process this file with automake to produce Makefile.in
 
-NULL =
 EXTRA_DIST =
 CLEANFILES =
 DISTCLEANFILES =
 MAINTAINERCLEANFILES =
 
+include Makefile.sources
+
 # Convenience targets:
 lib:
        @$(MAKE) $(AM_MAKEFLAGS) -C $(top_builddir)/src lib
@@ -31,21 +32,7 @@ if HAVE_GLIB
 
 if HAVE_FREETYPE
 if HAVE_CAIRO_FT
-hb_view_SOURCES = \
-       hb-view.cc \
-       options.cc \
-       options.hh \
-       main-font-text.hh \
-       shape-consumer.hh \
-       ansi-print.cc \
-       ansi-print.hh \
-       helper-cairo.cc \
-       helper-cairo.hh \
-       helper-cairo-ansi.cc \
-       helper-cairo-ansi.hh \
-       view-cairo.cc \
-       view-cairo.hh \
-       $(NULL)
+hb_view_SOURCES = $(HB_VIEW_sources)
 hb_view_LDADD = \
        $(LDADD) \
        $(CAIRO_LIBS) \
@@ -55,25 +42,29 @@ bin_PROGRAMS += hb-view
 endif # HAVE_CAIRO_FT
 endif # HAVE_FREETYPE
 
-hb_shape_SOURCES = \
-       hb-shape.cc \
-       options.cc \
-       options.hh \
-       main-font-text.hh \
-       shape-consumer.hh \
-       $(NULL)
+hb_shape_SOURCES = $(HB_SHAPE_sources)
 bin_PROGRAMS += hb-shape
 
 if HAVE_OT
-hb_ot_shape_closure_SOURCES = \
-       hb-ot-shape-closure.cc \
-       options.cc \
-       options.hh \
-       main-font-text.hh \
-       $(NULL)
+hb_ot_shape_closure_SOURCES = $(HB_OT_SHAPE_CLOSURE_sources)
 bin_PROGRAMS += hb-ot-shape-closure
 endif # HAVE_OT
 
 endif # HAVE_GLIB
 
+#if HAVE_OT
+#if HAVE_FONTCONFIG
+#hb_fc_list_SOURCES = \
+#      hb-fc.cc \
+#      hb-fc.h \
+#      hb-fc-list.c \
+#      $(NULL)
+#hb_fc_list_LDADD = \
+#      $(LDADD) \
+#      $(FONTCONFIG_LIBS) \
+#      $(NULL)
+#bin_PROGRAMS += hb-fc-list
+#endif # HAVE_FONTCONFIG
+#endif # HAVE_OT
+
 -include $(top_srcdir)/git.mk