Imported Upstream version 0.9.12
[platform/upstream/harfbuzz.git] / test / api / Makefile.am
index e6c0c01..237f92c 100644 (file)
@@ -21,11 +21,21 @@ TEST_PROGS = \
        test-common \
        test-font \
        test-object \
+       test-set \
        test-shape \
        test-unicode \
        test-version \
        $(NULL)
 
+test_unicode_CPPFLAGS = $(AM_CPPFLAGS)
+if HAVE_GLIB
+test_unicode_CPPFLAGS += $(GLIB_CFLAGS)
+endif
+if HAVE_ICU
+test_unicode_CPPFLAGS += $(ICU_CFLAGS)
+endif
+
+
 if HAVE_OT
 TEST_PROGS += \
        test-ot-tag \
@@ -49,7 +59,6 @@ test_c_CPPFLAGS += $(FREETYPE_CFLAGS)
 test_cplusplus_CPPFLAGS += $(FREETYPE_CFLAGS)
 endif
 
-
 # Default test running environment
 TESTS = $(TEST_PROGS)
 TESTS_ENVIRONMENT = \