Imported Upstream version 8.2.2
[platform/upstream/harfbuzz.git] / subprojects / packagefiles / ragel / meson.build
index cd317c2..4123ef2 100644 (file)
@@ -1,7 +1,15 @@
 project('ragel', 'c', 'cpp',
-  version : '6.10'
+  version : '6.10',
+  default_options: [
+    'cpp_eh=default',
+  ],
 )
 
+cpp = meson.get_compiler('cpp')
+add_project_arguments(cpp.get_supported_arguments([
+  '-fexceptions',
+]), language: 'cpp')
+
 conf = configuration_data()
 conf.set_quoted('PACKAGE', meson.project_name())
 conf.set_quoted('VERSION', meson.project_version())