Imported Upstream version 2.1.12
[platform/upstream/gpg2.git] / g13 / Makefile.am
index e17d099..05963c8 100644 (file)
 EXTRA_DIST = ChangeLog-2011
 
 bin_PROGRAMS = g13
+sbin_PROGRAMS = g13-syshelp
+
+noinst_PROGRAMS = $(module_tests)
+TESTS = $(module_tests)
 
 AM_CPPFLAGS = -I$(top_srcdir)/common
 
@@ -31,17 +35,45 @@ AM_CFLAGS =  $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(NPTH_CFLAGS)
 g13_SOURCES = \
        g13.c g13.h \
        g13-common.c g13-common.h \
-       keyblob.h \
-       utils.c utils.h \
+       keyblob.c keyblob.h \
+       g13tuple.c g13tuple.h \
        server.c server.h \
        create.c create.h \
        mount.c mount.h \
+       suspend.c suspend.h \
        mountinfo.c mountinfo.h \
+       call-syshelp.c call-syshelp.h \
        runner.c runner.h \
        backend.c backend.h \
        be-encfs.c be-encfs.h \
-       be-truecrypt.c be-truecrypt.h
+       be-truecrypt.c be-truecrypt.h \
+       be-dmcrypt.c be-dmcrypt.h
 
 g13_LDADD = $(libcommonpth) \
        $(LIBGCRYPT_LIBS) $(LIBASSUAN_LIBS) $(NPTH_LIBS) \
        $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV)
+
+
+g13_syshelp_SOURCES = \
+       g13-syshelp.c g13-syshelp.h \
+       g13-common.c g13-common.h \
+       keyblob.h \
+       g13tuple.c g13tuple.h \
+       sh-cmd.c \
+       sh-blockdev.c \
+       sh-dmcrypt.c
+
+g13_syshelp_LDADD = $(libcommon) \
+       $(LIBGCRYPT_LIBS) $(LIBASSUAN_LIBS) \
+       $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV)
+
+
+module_tests = t-g13tuple
+t_common_ldadd = $(libcommon) $(LIBGCRYPT_LIBS) \
+                $(LIBASSUAN_LIBS)
+
+t_g13tuple_SOURCES = t-g13tuple.c g13tuple.c
+t_g13tuple_LDADD = $(t_common_ldadd)
+
+
+$(PROGRAMS) : $(libcommon) $(libcommonpth)