Tizen 2.1 base
[platform/upstream/glib2.0.git] / tests / gobject / Makefile.am
index 9cfb33b..fcb4e23 100644 (file)
@@ -1,9 +1,8 @@
 include $(top_srcdir)/Makefile.decl
 
 INCLUDES =                                     \
-       -I$(top_srcdir)                         \
-       -I$(top_srcdir)/glib                    \
-       -I$(top_srcdir)/gmodule                 \
+       $(gmodule_INCLUDES)                     \
+       -DGLIB_DISABLE_DEPRECATION_WARNINGS     \
        $(GLIB_DEBUG_FLAGS)
 
 libglib = $(top_builddir)/glib/libglib-2.0.la
@@ -37,12 +36,12 @@ endif
 testmarshal.h: stamp-testmarshal.h
        @true
 stamp-testmarshal.h: @REBUILD@ testmarshal.list $(glib_genmarshal)
-       $(glib_genmarshal) --prefix=test_marshal $(srcdir)/testmarshal.list --header >> xgen-gmh \
+       $(AM_V_GEN) $(glib_genmarshal) --prefix=test_marshal $(srcdir)/testmarshal.list --header >> xgen-gmh \
        && (cmp -s xgen-gmh testmarshal.h 2>/dev/null || cp xgen-gmh testmarshal.h) \
        && rm -f xgen-gmh xgen-gmh~ \
        && echo timestamp > $@
 testmarshal.c: @REBUILD@ testmarshal.list $(glib_genmarshal)
-       $(glib_genmarshal) --prefix=test_marshal $(srcdir)/testmarshal.list --body >> xgen-gmc \
+       $(AM_V_GEN) $(glib_genmarshal) --prefix=test_marshal $(srcdir)/testmarshal.list --body >> xgen-gmc \
        && cp xgen-gmc testmarshal.c \
        && rm -f xgen-gmc xgen-gmc~
 
@@ -63,7 +62,6 @@ test_programs =                                       \
        ifacecheck                              \
        ifaceinit                               \
        ifaceinherit                            \
-       ifaceproperties                         \
        override                                \
        performance                             \
        performance-threaded                    \