Tizen 2.1 base
[platform/upstream/glib2.0.git] / gthread / Makefile.am
index 8252260..325fec4 100644 (file)
@@ -1,23 +1,14 @@
 ## Process this file with automake to produce Makefile.in
 include $(top_srcdir)/Makefile.decl
 
-SUBDIRS = . tests
-DIST_SUBDIRS = tests
-
 AM_CPPFLAGS =                          \
-       -I$(top_srcdir)                 \
-       -I$(top_srcdir)/glib            \
-       -I$(top_srcdir)/gthread         \
+       $(glib_INCLUDES)                \
        -DG_LOG_DOMAIN=\"GThread\"      \
        @GTHREAD_COMPILE_IMPL_DEFINES@  \
-       @GLIB_DEBUG_FLAGS@              \
-       -DG_DISABLE_DEPRECATED
+       @GLIB_DEBUG_FLAGS@
 
 EXTRA_DIST +=                          \
                makefile.msc.in         \
-               gthread-posix.c         \
-               gthread-win32.c         \
-               gthread-none.c          \
                gthread.def             \
                gthread.rc.in
 
@@ -70,7 +61,7 @@ gthread_win32_res_ldflag = -Wl,$(gthread_win32_res)
 endif
 
 libgthread_2_0_la_SOURCES = gthread-impl.c
-libgthread_2_0_la_LDFLAGS = \
+libgthread_2_0_la_LDFLAGS = $(GLIB_LINK_FLAGS) \
        $(gthread_win32_res_ldflag) \
        -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
        -export-dynamic $(no_undefined) $(export_symbols)
@@ -80,7 +71,7 @@ libgthread_2_0_la_LIBADD = $(G_THREAD_LIBS_EXTRA) $(G_THREAD_LIBS_FOR_GTHREAD) $
 libgthread_2_0_la_DEPENDENCIES = $(gthread_win32_res) $(gthread_def)
 
 gthread-win32-res.o: gthread.rc
-       $(WINDRES) gthread.rc $@
+       $(AM_V_GEN) $(WINDRES) gthread.rc $@
 
 gthread-2.0.lib: libgthread-2.0.la gthread.def
        lib -machine:@LIB_EXE_MACHINE_FLAG@ -name:libgthread-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:$(srcdir)/gthread.def -out:$@