Tizen 2.1 base
[platform/upstream/glib2.0.git] / gmodule / Makefile.am
index 93a8473..5e08c11 100644 (file)
@@ -2,15 +2,13 @@
 include $(top_srcdir)/Makefile.decl
 
 AM_CPPFLAGS =                          \
-       -I$(top_srcdir)                 \
-       -I$(top_srcdir)/glib            \
-       -I$(top_srcdir)/gmodule         \
+       $(glib_INCLUDES)                \
        -DG_LOG_DOMAIN=\"GModule\"      \
        @GLIB_DEBUG_FLAGS@              \
        -DG_DISABLE_DEPRECATED
 
 gmodule.def: gmodule.symbols
-       (echo -e EXPORTS; $(CPP) -P - <$(srcdir)/gmodule.symbols | sed -e '/^$$/d' -e 's/^/     /') > gmodule.def
+       $(AM_V_GEN) (echo EXPORTS; $(CPP) -P - <$(srcdir)/gmodule.symbols | sed -e '/^$$/d' -e 's/^/    /') > $(builddir)/gmodule.def
 
 EXTRA_DIST +=                          \
                makefile.msc.in         \
@@ -63,14 +61,14 @@ no_undefined = -no-undefined
 endif
 
 if OS_WIN32_AND_DLL_COMPILATION
-export_symbols = -export-symbols gmodule.def
+export_symbols = -export-symbols $(builddir)/gmodule.def
 gmodule_def = gmodule.def
 
 gmodule_win32_res = gmodule-win32-res.o
 gmodule_win32_res_ldflag = -Wl,$(gmodule_win32_res)
 
 install-def-file:
-       $(INSTALL) gmodule.def $(DESTDIR)$(libdir)/gmodule-2.0.def
+       $(INSTALL) $(builddir)/gmodule.def $(DESTDIR)$(libdir)/gmodule-2.0.def
 
 uninstall-def-file:
        -rm $(DESTDIR)$(libdir)/gmodule-2.0.def
@@ -80,7 +78,7 @@ uninstall-def-file:
 endif
 
 libgmodule_2_0_la_SOURCES = gmodule.c
-libgmodule_2_0_la_LDFLAGS = \
+libgmodule_2_0_la_LDFLAGS = $(GLIB_LINK_FLAGS) \
        $(gmodule_win32_res_ldflag) \
        $(G_MODULE_LDFLAGS) \
        -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
@@ -91,10 +89,10 @@ libgmodule_2_0_la_LIBADD = $(G_MODULE_LIBS_EXTRA) $(G_MODULE_LIBS) $(libglib)
 libgmodule_2_0_la_DEPENDENCIES = $(gmodule_win32_res) $(gmodule_def)
 
 gmodule-win32-res.o: gmodule.rc
-       $(WINDRES) gmodule.rc $@
+       $(AM_V_GEN) $(WINDRES) gmodule.rc $@
 
 gmodule-2.0.lib: libgmodule-2.0.la gmodule.def
-       lib -machine:@LIB_EXE_MACHINE_FLAG@ -name:libgmodule-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:gmodule.def -out:$@
+       lib -machine:@LIB_EXE_MACHINE_FLAG@ -name:libgmodule-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:$(builddir)/gmodule.def -out:$@
 
 .PHONY: files release