[kdbus] Make SipHash function as a private utility function to kdbus
[platform/upstream/glib.git] / glib / Makefile.am
index 9bcfe2b..6b8e629 100644 (file)
@@ -1,9 +1,5 @@
 ## Process this file with automake to produce Makefile.in
-include $(top_srcdir)/Makefile.decl
-
-BUILT_SOURCES =
-DISTCLEANFILES =
-CLEANFILES =
+include $(top_srcdir)/glib.mk
 
 #
 # Generate glibconfig.h
@@ -30,26 +26,12 @@ PRINTF_SUBDIR = gnulib
 printf_la = gnulib/libgnulib.la
 endif 
 
-if ENABLE_REGEX
 if USE_SYSTEM_PCRE
 else
 MAYBE_PCRE = pcre 
 endif
-gregex_c = gregex.c
-gregex_h = gregex.h
-else
-gregex_c =
-gregex_h =
-endif
-
-if HAVE_GCC_BUILTINS_FOR_ATOMIC_OPERATIONS
-gatomic_c = gatomic-gcc.c
-else
-gatomic_c = gatomic.c
-endif
 
 SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
-
 DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
 
 AM_CPPFLAGS =                          \
@@ -57,19 +39,10 @@ AM_CPPFLAGS =                               \
        $(pcre_inc)                     \
        -DG_LOG_DOMAIN=\"GLib\"         \
        $(GLIB_DEBUG_FLAGS)             \
-       -DG_DISABLE_DEPRECATED          \
        -DGLIB_COMPILATION              \
        -DPCRE_STATIC
 
-glib.def: glib.symbols
-       $(AM_V_GEN) (echo -e EXPORTS; $(CPP) -P -DINCLUDE_VARIABLES -DINCLUDE_INTERNAL_SYMBOLS -DG_OS_WIN32 -DALL_FILES - <$(srcdir)/glib.symbols | sed -e '/^$$/d' -e 's/^/    /' -e 's/G_GNUC_[^ ]*//g') > glib.def
-
-if OS_LINUX
-if HAVE_GNUC_VISIBILITY
-TESTS_ENVIRONMENT = GLIB_DEBUG_FLAGS="$(GLIB_DEBUG_FLAGS)"
-TESTS = abicheck.sh
-endif
-endif
+AM_CFLAGS = $(GLIB_WARN_CFLAGS)
 
 MIRRORING_TAB_SOURCE =                                 \
        glib-mirroring-tab/Makefile             \
@@ -82,20 +55,20 @@ MIRRORING_TAB_SOURCE =                              \
 EXTRA_DIST +=                  \
        makefile.msc.in         \
        glib.rc.in              \
-       gen-iswide-table.py     \
        gen-unicode-tables.pl   \
-       gen-script-table.pl     \
        glibconfig.h.win32.in   \
-       abicheck.sh             \
-       glib.symbols            \
        gregex.c                \
        gregex.h                \
        win_iconv.c             \
        libglib-gdb.py.in       \
+       docs.c                  \
+       gconstructor.h          \
        $(MIRRORING_TAB_SOURCE)
 
+CLEANFILES += libglib-gdb.py
+
 # These may be in the builddir too
-BUILT_EXTRA_DIST             \
+BUILT_EXTRA_DIST +=            \
        makefile.msc            \
        glibconfig.h.win32      \
        glib.rc
@@ -104,7 +77,7 @@ lib_LTLIBRARIES = libglib-2.0.la
 
 if OS_WIN32_AND_DLL_COMPILATION
 if MS_LIB_AVAILABLE
-noinst_DATA = glib-2.0.lib
+noinst_DATA += glib-2.0.lib
 
 install_ms_lib_cmd = $(INSTALL) glib-2.0.lib $(DESTDIR)$(libdir)
 uninstall_ms_lib_cmd = -rm $(DESTDIR)$(libdir)/glib-2.0.lib
@@ -117,37 +90,55 @@ install-ms-lib:
 uninstall-ms-lib:
        $(uninstall_ms_lib_cmd)
 
+deprecated_sources = \
+       deprecated/gallocator.c         \
+       deprecated/gcache.c             \
+       deprecated/gcompletion.c        \
+       deprecated/grel.c               \
+       deprecated/gthread-deprecated.c
+
 libglib_2_0_la_SOURCES =       \
+       $(deprecated_sources)   \
        glib_probes.d           \
        garray.c                \
        gasyncqueue.c           \
-       $(gatomic_c)            \
+       gasyncqueueprivate.h    \
+       gatomic.c               \
        gbacktrace.c            \
        gbase64.c               \
        gbitlock.c              \
        gbookmarkfile.c         \
        gbsearcharray.h         \
-       gbuffer.c               \
-       gbuffer.h               \
-       gcache.c                \
+       gbytes.c                \
+       gbytes.h                \
+       gcharset.c              \
+       gcharsetprivate.h       \
        gchecksum.c             \
-       gcompletion.c           \
        gconvert.c              \
        gdataset.c              \
        gdatasetprivate.h       \
        gdate.c                 \
        gdatetime.c             \
        gdir.c                  \
+       genviron.c              \
        gerror.c                \
        gfileutils.c            \
+       ggettext.c              \
        ghash.c                 \
+       ghmac.c                 \
        ghook.c                 \
        ghostutils.c            \
        giochannel.c            \
        gkeyfile.c              \
        glibintl.h              \
        glib_trace.h            \
+       glib-init.h             \
+       glib-init.c             \
+       glib-linux.h            \
+       glib-private.h          \
+       glib-private.c          \
        glist.c                 \
+       gmain-internal.h        \
        gmain.c                 \
        gmappedfile.c           \
        gmarkup.c               \
@@ -160,10 +151,10 @@ libglib_2_0_la_SOURCES =  \
        gpoll.c                 \
        gprimes.c               \
        gqsort.c                \
+       gquark.c                \
        gqueue.c                \
-       grel.c                  \
        grand.c                 \
-       $(gregex_c)             \
+       gregex.c                \
        gscanner.c              \
        gscripttable.h          \
        gsequence.c             \
@@ -173,12 +164,16 @@ libglib_2_0_la_SOURCES =  \
        gstdio.c                \
        gstrfuncs.c             \
        gstring.c               \
+       gstringchunk.c          \
        gtestutils.c            \
-       gthread.c               \
+       gthread.c               \
        gthreadprivate.h        \
-       gthreadpool.c           \
+       gthreadpool.c           \
        gtimer.c                \
        gtimezone.c             \
+       gtranslit.c             \
+       gtranslit-data.h        \
+       gtrashstack.c           \
        gtree.c                 \
        guniprop.c              \
        gutf8.c                 \
@@ -200,16 +195,29 @@ libglib_2_0_la_SOURCES =  \
        gvariant-parser.c       \
        gvariant-serialiser.h   \
        gvariant-serialiser.c   \
+       gvariant-vectors.h      \
+       gvariant-vectors.c      \
        gvarianttypeinfo.h      \
        gvarianttypeinfo.c      \
        gvarianttype.c          \
-       gdebug.h                \
+       gversion.c              \
+       gwakeup.h               \
+       gwakeup.c               \
        gprintf.c               \
-       gprintfint.h
+       gprintfint.h            \
+       valgrind.h
 
 if OS_UNIX
 libglib_2_0_la_SOURCES += glib-unix.c
-endif  
+endif
+
+if THREADS_WIN32
+libglib_2_0_la_SOURCES += gthread-win32.c
+else
+if THREADS_POSIX
+libglib_2_0_la_SOURCES += gthread-posix.c
+endif
+endif
 
 EXTRA_libglib_2_0_la_SOURCES = \
        giounix.c       \
@@ -220,15 +228,21 @@ EXTRA_libglib_2_0_la_SOURCES = \
 
 glibincludedir=$(includedir)/glib-2.0
 glibinclude_HEADERS =   \
+       glib-unix.h     \
        glib-object.h   \
        glib.h
 
-if OS_UNIX
-glibinclude_HEADERS += glib-unix.h
-endif
+deprecatedincludedir=$(includedir)/glib-2.0/glib/deprecated
+deprecatedinclude_HEADERS = \
+       deprecated/gallocator.h         \
+       deprecated/gcache.h             \
+       deprecated/gcompletion.h        \
+       deprecated/gmain.h              \
+       deprecated/grel.h               \
+       deprecated/gthread.h
 
 glibsubincludedir=$(includedir)/glib-2.0/glib
-glibsubinclude_HEADERS =   \
+glibsubinclude_HEADERS = \
        galloca.h       \
        garray.h        \
        gasyncqueue.h   \
@@ -236,18 +250,21 @@ glibsubinclude_HEADERS =   \
        gbacktrace.h    \
        gbase64.h       \
        gbitlock.h      \
-       gbookmarkfile.h \
-       gcache.h        \
+       gbookmarkfile.h \
+       gbytes.h        \
+       gcharset.h      \
        gchecksum.h     \
-       gcompletion.h   \
        gconvert.h      \
        gdataset.h      \
        gdate.h         \
-       gdatetime.h     \
+       gdatetime.h     \
        gdir.h          \
+       genviron.h      \
        gerror.h        \
        gfileutils.h    \
+       ggettext.h      \
        ghash.h         \
+       ghmac.h         \
        ghook.h         \
        ghostutils.h    \
        gi18n.h         \
@@ -270,8 +287,7 @@ glibsubinclude_HEADERS =   \
        gquark.h        \
        gqueue.h        \
        grand.h         \
-       $(gregex_h)     \
-       grel.h          \
+       gregex.h        \
        gscanner.h      \
        gsequence.h     \
        gshell.h        \
@@ -282,10 +298,12 @@ glibsubinclude_HEADERS =   \
        gstrfuncs.h     \
        gtestutils.h    \
        gstring.h       \
+       gstringchunk.h  \
        gthread.h       \
        gthreadpool.h   \
        gtimer.h        \
        gtimezone.h     \
+       gtrashstack.h   \
        gtree.h         \
        gtypes.h        \
        gunicode.h      \
@@ -293,43 +311,37 @@ glibsubinclude_HEADERS =   \
        gutils.h        \
        gvarianttype.h  \
        gvariant.h      \
+       gversion.h      \
+       gversionmacros.h \
        gwin32.h        \
        gprintf.h
 
-install-data-local: install-ms-lib install-def-file
+# This is read by gobject-introspection/misc/ and gtk-doc
+glib-public-headers.txt: Makefile
+       echo $(glibinclude_HEADERS) $(glibsubinclude_HEADERS) > $@.tmp && mv $@.tmp $@
+
+CLEANFILES += glib-public-headers.txt
+
+all-local: glib-public-headers.txt
+
+install-data-local: install-ms-lib
        @if test -f $(glibincludedir)/glist.h ; then                                    \
          echo "*** Old headers found in $(glibincludedir). You should remove the" ;    \
          echo "*** contents of this directory and type 'make install' again." ;        \
          false ;                                                                       \
        fi
 
-uninstall-local: uninstall-ms-lib uninstall-def-file
+uninstall-local: uninstall-ms-lib uninstall-gdb
 
 if PLATFORM_WIN32
 no_undefined = -no-undefined
 endif
 
 if OS_WIN32_AND_DLL_COMPILATION
-export_symbols = -export-symbols glib.def
-
 glib_win32_res = glib-win32-res.o
 glib_win32_res_ldflag = -Wl,$(glib_win32_res)
-
-glib_def = glib.def
-
-install-def-file:
-       $(INSTALL) glib.def $(DESTDIR)$(libdir)/glib-2.0.def
-
-uninstall-def-file:
-       -rm $(DESTDIR)$(libdir)/glib-2.0.def
-else
-install-def-file:
-uninstall-def-file:
-
-export_symbols = $(LIBTOOL_EXPORT_OPTIONS)
 endif
 
-if ENABLE_REGEX
 if USE_SYSTEM_PCRE
 pcre_lib = $(PCRE_LIBS)
 pcre_inc = $(PCRE_CFLAGS)
@@ -337,30 +349,32 @@ else
 pcre_lib = pcre/libpcre.la
 pcre_inc =
 endif
-else
-pcre_lib =
-pcre_inc =
-endif
 
-libglib_2_0_la_LIBADD = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ @ICONV_LIBS@ @G_LIBS_EXTRA@ $(pcre_lib) $(GLIB_RT_LIBS)
+libglib_2_0_la_CFLAGS = $(AM_CFLAGS) $(GLIB_HIDDEN_VISIBILITY_CFLAGS)
+libglib_2_0_la_LIBADD = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ @ICONV_LIBS@ @G_LIBS_EXTRA@ $(pcre_lib) $(G_THREAD_LIBS_EXTRA) $(G_THREAD_LIBS_FOR_GTHREAD)
 libglib_2_0_la_DEPENDENCIES = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ $(glib_win32_res) $(glib_def)
 
 libglib_2_0_la_LDFLAGS = $(GLIB_LINK_FLAGS) \
         $(glib_win32_res_ldflag) \
        -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-       -export-dynamic $(no_undefined) $(export_symbols)
+       -export-dynamic $(no_undefined)
 
 INSTALL_PROGS=
 
 if ENABLE_DTRACE
-glib_probes.h: glib_probes.d Makefile
-       $(DTRACE) -C -h -s $< -o $@.tmp
-       sed -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
-glib_probes.o: glib_probes.d Makefile
-       $(DTRACE) -G -s $< -o $@
-BUILT_SOURCES += glib_probes.h glib_probes.o
+DTCOMPILE = $(patsubst -W%,,$(LTCOMPILE))
+DTCFLAGS = $(patsubst -W%,,$(CFLAGS))
+
+glib_probes.h: glib_probes.d
+       $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
+       @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
+
+glib_probes.lo: glib_probes.d
+       $(AM_V_GEN) env CC="$(DTCOMPILE)" CFLAGS="$(DTCFLAGS)" $(DTRACE) -G -s $< -o $@
+
+BUILT_SOURCES += glib_probes.h glib_probes.lo
 CLEANFILES += glib_probes.h glib_probes.h.tmp
-libglib_2_0_la_LIBADD += glib_probes.o
+libglib_2_0_la_LIBADD += glib_probes.lo
 endif
 
 if ENABLE_SYSTEMTAP
@@ -420,7 +434,7 @@ install-exec-hook:
          mv -f "$(DESTDIR)$(bindir)/$$sf" "$(DESTDIR)$(bindir)/$$sf".tmp \
          && sed < "$(DESTDIR)$(bindir)/$$sf".tmp > "$(DESTDIR)$(bindir)/$$sf" \
            -e '1,24s|^ *#@PKGINSTALL_CONFIGVARS_IN24LINES@|  ${CONFIGVARS}|' \
-           -e '1,1s|#! /usr/bin/env python\([0-9]\+\(\.[0-9]\+\)\?\)\?|#!${PYTHON}|' \
+           -e '1,1s|#! /usr/bin/env python.*|#!${PYTHON}|' \
          || exit $$? ; \
          chmod a+x $(DESTDIR)$(bindir)/$$sf ; \
          rm -f "$(DESTDIR)$(bindir)/$$sf".tmp ; \
@@ -428,8 +442,11 @@ install-exec-hook:
 
 endif
 
+glib.def: libglib-2.0.la
+       $(AM_V_GEN) dumpbin.exe -exports .libs/libglib-2.0-0.dll | awk 'BEGIN { print "EXPORTS" } / +[[:digit:]]+ +[[:xdigit:]]+ +[[:xdigit:]]+/{ print $$4 }' > glib.def.tmp && mv glib.def.tmp glib.def
+
 glib-2.0.lib: libglib-2.0.la glib.def
-       lib -machine:@LIB_EXE_MACHINE_FLAG@ -name:libglib-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:glib.def -out:$@
+       $(AM_V_GEN) lib.exe -machine:@LIB_EXE_MACHINE_FLAG@ -name:libglib-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:$(builddir)/glib.def -out:$@
 
 dist-hook: $(BUILT_EXTRA_DIST) ../build/win32/vs9/glib.vcproj ../build/win32/vs10/glib.vcxproj ../build/win32/vs10/glib.vcxproj.filters
        files='$(BUILT_EXTRA_DIST)'; \
@@ -438,9 +455,9 @@ dist-hook: $(BUILT_EXTRA_DIST) ../build/win32/vs9/glib.vcproj ../build/win32/vs1
          cp $$d/$$f $(distdir) || exit 1; done
 
 ../build/win32/vs9/glib.vcproj: $(top_srcdir)/build/win32/vs9/glib.vcprojin
-       for F in $(libglib_2_0_la_SOURCES); do \
+       for F in `echo $(libglib_2_0_la_SOURCES) | tr '/' '\\'`; do \
                case $$F in \
-               *-gcc.c) \
+               *-unix.c|gthread-*.c) \
                        ;; \
                *.c)    echo '   <File RelativePath="..\..\..\glib\'$$F'" />' \
                        ;; \
@@ -450,9 +467,9 @@ dist-hook: $(BUILT_EXTRA_DIST) ../build/win32/vs9/glib.vcproj ../build/win32/vs1
        rm libglib.sourcefiles
 
 ../build/win32/vs10/glib.vcxproj: $(top_srcdir)/build/win32/vs10/glib.vcxprojin
-       for F in $(libglib_2_0_la_SOURCES); do \
+       for F in `echo $(libglib_2_0_la_SOURCES) | tr '/' '\\'`; do \
                case $$F in \
-               *-gcc.c) \
+               *-unix.c|gthread-*.c) \
                        ;; \
                *.c) echo '    <ClCompile Include="..\..\..\glib\'$$F'" />' \
                     ;; \
@@ -462,9 +479,9 @@ dist-hook: $(BUILT_EXTRA_DIST) ../build/win32/vs9/glib.vcproj ../build/win32/vs1
        rm libglib.vs10.sourcefiles
 
 ../build/win32/vs10/glib.vcxproj.filters: $(top_srcdir)/build/win32/vs10/glib.vcxproj.filtersin
-       for F in $(libglib_2_0_la_SOURCES); do \
+       for F in `echo $(libglib_2_0_la_SOURCES) | tr '/' '\\'`; do \
                case $$F in \
-               *-gcc.c) \
+               *-unix.c|gthread-*.c) \
                        ;; \
                *.c) echo '    <ClCompile Include="..\..\..\glib\'$$F'"><Filter>Source Files</Filter></ClCompile>' \
                     ;; \
@@ -473,22 +490,17 @@ dist-hook: $(BUILT_EXTRA_DIST) ../build/win32/vs9/glib.vcproj ../build/win32/vs1
        $(CPP) -P - <$(top_srcdir)/build/win32/vs10/glib.vcxproj.filtersin >$@  
        rm libglib.vs10.sourcefiles.filters
 
-distclean-local:
-       if test $(srcdir) = .; then :; else \
-           rm -f libglib-gdb.py; \
-       fi
-
 # install gdb scripts
 gdbdir = $(datadir)/glib-2.0/gdb
 dist_gdb_SCRIPTS = glib.py
 
 libglib-gdb.py: libglib-gdb.py.in
-       $(AM_V_GEN) $(SED) -e "s|\@datadir\@|$(datadir)|" $(srcdir)/libglib-gdb.py.in > libglib-gdb.py
+       $(AM_V_GEN) $(SED) -e "s|\@datadir\@|$(datadir)|" $(srcdir)/libglib-gdb.py.in > $(builddir)/libglib-gdb.py
 
 
 install-data-hook: libglib-gdb.py
        mkdir -p $(DESTDIR)$(datadir)/gdb/auto-load$(ABS_GLIB_RUNTIME_LIBDIR)
-       $(INSTALL) libglib-gdb.py $(DESTDIR)$(datadir)/gdb/auto-load$(ABS_GLIB_RUNTIME_LIBDIR)/libglib-2.0.so.0.$(LT_CURRENT).$(LT_REVISION)-gdb.py
+       $(INSTALL) $(builddir)/libglib-gdb.py $(DESTDIR)$(datadir)/gdb/auto-load$(ABS_GLIB_RUNTIME_LIBDIR)/libglib-2.0.so.0.$(LT_CURRENT).$(LT_REVISION)-gdb.py
 if HAVE_GLIB_RUNTIME_LIBDIR
        mkdir -p $(DESTDIR)$(libdir)/$(GLIB_RUNTIME_LIBDIR)
        mv $(DESTDIR)$(libdir)/libglib-2.0.so.0 $(DESTDIR)$(libdir)/$(GLIB_RUNTIME_LIBDIR)
@@ -496,3 +508,6 @@ if HAVE_GLIB_RUNTIME_LIBDIR
        rm -f $(DESTDIR)$(libdir)/libglib-2.0.so
        ln -s $(GLIB_RUNTIME_LIBDIR)/libglib-2.0.so.0.$(LT_CURRENT).$(LT_REVISION) $(DESTDIR)$(libdir)/libglib-2.0.so
 endif
+
+uninstall-gdb:
+       -rm -r $(DESTDIR)$(datadir)/gdb