[kdbus] Integrate kdbus core with new API.
[platform/upstream/glib.git] / gio / Makefile.am
index b4edecf..bc77dc1 100644 (file)
@@ -1,6 +1,4 @@
-include $(top_srcdir)/Makefile.decl
-
-NULL =
+include $(top_srcdir)/glib.mk
 
 SUBDIRS = gdbus-2.0/codegen
 
@@ -10,7 +8,7 @@ endif
 
 if OS_WIN32_AND_DLL_COMPILATION
 if MS_LIB_AVAILABLE
-noinst_DATA = gio-2.0.lib
+noinst_DATA += gio-2.0.lib
 
 install_ms_lib_cmd = $(INSTALL) gio-2.0.lib $(DESTDIR)$(libdir)
 uninstall_ms_lib_cmd = -rm $(DESTDIR)$(libdir)/gio-2.0.lib
@@ -23,12 +21,6 @@ install-ms-lib:
 uninstall-ms-lib:
        $(uninstall_ms_lib_cmd)
 
-if OS_LINUX
-if HAVE_GNUC_VISIBILITY
-TESTS = abicheck.sh
-endif
-endif
-
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"GLib-GIO\"                     \
        $(gmodule_INCLUDES)                             \
@@ -36,6 +28,8 @@ AM_CPPFLAGS = \
        -DGIO_COMPILATION                               \
        -DGIO_MODULE_DIR=\"$(GIO_MODULE_DIR)\"  
 
+AM_CFLAGS = $(GLIB_WARN_CFLAGS)
+
 lib_LTLIBRARIES = libgio-2.0.la
 
 gdbus_headers =                        \
@@ -151,12 +145,14 @@ application_headers = \
        gactiongroupexporter.h          \
        gdbusactiongroup.h              \
        gaction.h                       \
+       gpropertyaction.h               \
        gsimpleaction.h                 \
                                        \
        gmenumodel.h                    \
        gmenu.h                         \
        gmenuexporter.h                 \
        gdbusmenumodel.h                \
+       gnotification.h                 \
        $(NULL)
 
 application_sources = \
@@ -173,12 +169,17 @@ application_sources = \
        gdbusactiongroup-private.h              \
        gdbusactiongroup.c                      \
        gaction.c                               \
+       gpropertyaction.c                       \
        gsimpleaction.c                         \
                                                \
        gmenumodel.c                            \
        gmenu.c                                 \
        gmenuexporter.c                         \
        gdbusmenumodel.c                        \
+       gnotification-private.h                 \
+       gnotificationbackend.h                  \
+       gnotification.c                         \
+       gnotificationbackend.c                  \
        $(NULL)
 
 local_sources = \
@@ -206,6 +207,8 @@ local_sources = \
        gsocks4aproxy.h                 \
        gsocks5proxy.c                  \
        gsocks5proxy.h                  \
+       thumbnail-verify.h              \
+       thumbnail-verify.c              \
        $(NULL)
 
 platform_libadd =
@@ -237,7 +240,7 @@ platform_libadd += win32/libgiowin32.la
 platform_deps += win32/libgiowin32.la
 endif
 
-SUBDIRS += .
+SUBDIRS += . tests
 
 if HAVE_FAM
 SUBDIRS += fam
@@ -245,7 +248,7 @@ endif
 
 if OS_UNIX
 appinfo_sources += gdesktopappinfo.c
-platform_libadd += xdgmime/libxdgmime.la $(RESOLVER_LIBADD)
+platform_libadd += xdgmime/libxdgmime.la
 platform_deps += xdgmime/libxdgmime.la
 unix_sources = \
        gfiledescriptorbased.c  \
@@ -265,6 +268,8 @@ unix_sources = \
        gunixoutputstream.c     \
        gcontenttype.c          \
        gcontenttypeprivate.h   \
+       gfdonotificationbackend.c \
+       ggtknotificationbackend.c \
        $(NULL)
 
 
@@ -320,7 +325,7 @@ win32_more_sources_for_vcproj = \
 
 if OS_WIN32
 appinfo_sources += gwin32appinfo.c gwin32appinfo.h
-platform_libadd += -lshlwapi -lws2_32 -ldnsapi
+platform_libadd += -lshlwapi -lws2_32 -ldnsapi -liphlpapi
 win32_sources = $(win32_actual_sources)
 
 giowin32includedir=$(includedir)/gio-win32-2.0/gio
@@ -331,24 +336,23 @@ giowin32include_HEADERS = \
 
 endif
 
-if BUILD_MODULAR_TESTS
-SUBDIRS += tests 
-endif
-
 libgio_2_0_la_SOURCES =                \
        gappinfo.c              \
+       gappinfoprivate.h       \
        gasynchelper.c          \
        gasynchelper.h          \
        gasyncinitable.c        \
        gasyncresult.c          \
        gbufferedinputstream.c  \
        gbufferedoutputstream.c \
+       gbytesicon.c            \
        gcancellable.c          \
        gcharsetconverter.c     \
        gconverter.c            \
        gconverterinputstream.c \
        gconverteroutputstream.c        \
        gcredentials.c          \
+       gcredentialsprivate.h   \
        gdatainputstream.c      \
        gdataoutputstream.c     \
        gdrive.c                \
@@ -388,7 +392,11 @@ libgio_2_0_la_SOURCES =            \
        giomodule-priv.h        \
        gioscheduler.c          \
        giostream.c             \
+       gioprivate.h            \
+       giowin32-priv.h         \
        gloadableicon.c         \
+       gkdbus.c                \
+       gkdbusconnection.c      \
        gmount.c                \
        gmemoryinputstream.c    \
        gmemoryoutputstream.c   \
@@ -409,6 +417,9 @@ libgio_2_0_la_SOURCES =             \
        gpollableutils.c        \
        gpollfilemonitor.c      \
        gpollfilemonitor.h      \
+       gproxy.c                \
+       gproxyaddress.c         \
+       gproxyaddressenumerator.c \
        gproxyresolver.c        \
        gresolver.c             \
        gresource.c             \
@@ -429,11 +440,12 @@ libgio_2_0_la_SOURCES =           \
        gsocketlistener.c       \
        gsocketoutputstream.c   \
        gsocketoutputstream.h   \
-       gproxy.c                \
-       gproxyaddress.c         \
-       gproxyaddressenumerator.c \
+       gsubprocesslauncher.c   \
+       gsubprocess.c           \
+       gsubprocesslauncher-private.h   \
        gsocketservice.c        \
        gsrvtarget.c            \
+       gsimpleproxyresolver.c  \
        gtask.c                 \
        gtcpconnection.c        \
        gtcpwrapperconnection.c \
@@ -472,9 +484,9 @@ libgio_2_0_la_SOURCES =             \
 EXTRA_DIST += strinfo.c
 
 libgio_2_0_la_LIBADD = \
-       $(top_builddir)/glib/libglib-2.0.la             \
        $(top_builddir)/gobject/libgobject-2.0.la       \
        $(top_builddir)/gmodule/libgmodule-2.0.la       \
+       $(top_builddir)/glib/libglib-2.0.la             \
        $(platform_libadd)                              \
        $(ZLIB_LIBS)                                    \
        $(SELINUX_LIBS)                                 \
@@ -492,8 +504,6 @@ endif
 if OS_WIN32_AND_DLL_COMPILATION
 gio_win32_res = gio-win32-res.o
 gio_win32_res_ldflag = -Wl,$(gio_win32_res)
-else
-export_symbols = $(LIBTOOL_EXPORT_OPTIONS)
 endif
 
 install-data-local: install-ms-lib
@@ -501,14 +511,15 @@ install-data-local: install-ms-lib
 
 uninstall-local: uninstall-ms-lib
 
+libgio_2_0_la_CFLAGS = $(AM_CFLAGS) $(GLIB_HIDDEN_VISIBILITY_CFLAGS)
 libgio_2_0_la_LDFLAGS = $(GLIB_LINK_FLAGS) \
        $(gio_win32_res_ldflag) \
        -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-       -export-dynamic $(no_undefined) $(export_symbols)
+       -export-dynamic $(no_undefined)
 
 if OS_COCOA
 # This is dumb.  The ObjC source file should be properly named .m
-libgio_2_0_la_CFLAGS = -xobjective-c
+libgio_2_0_la_CFLAGS += -xobjective-c
 libgio_2_0_la_LDFLAGS += -Wl,-framework,Foundation
 endif
 
@@ -523,6 +534,7 @@ gio_headers =                       \
        gasyncresult.h          \
        gbufferedinputstream.h  \
        gbufferedoutputstream.h \
+       gbytesicon.h            \
        gcancellable.h          \
        gcontenttype.h          \
        gcharsetconverter.h     \
@@ -559,6 +571,8 @@ gio_headers =                       \
        giomodule.h             \
        gioscheduler.h          \
        giostream.h             \
+       gkdbus.h                \
+       gkdbusconnection.h      \
        gloadableicon.h         \
        gmount.h                \
        gmemoryinputstream.h    \
@@ -566,7 +580,6 @@ gio_headers =                       \
        gmountoperation.h       \
        gnativevolumemonitor.h  \
        gnetworkaddress.h       \
-       gnetworking.h           \
        gnetworkmonitor.h       \
        gnetworkservice.h       \
        goutputstream.h         \
@@ -593,7 +606,10 @@ gio_headers =                      \
        gsocketlistener.h       \
        gsocketservice.h        \
        gsrvtarget.h            \
+       gsimpleproxyresolver.h  \
        gtask.h                 \
+       gsubprocess.h           \
+       gsubprocesslauncher.h   \
        gtcpconnection.h        \
        gtcpwrapperconnection.h \
        gthreadedsocketservice.h\
@@ -622,8 +638,12 @@ gioinclude_HEADERS =               \
        $(gio_headers)          \
        gioenumtypes.h
 
+nodist_gioinclude_HEADERS =    \
+       gnetworking.h           \
+       $(NULL)
+
 # these sources (also mentioned above) are generated.
-BUILT_SOURCES                \
+BUILT_SOURCES +=               \
        gconstructor_as_data.h  \
        gioenumtypes.h          \
        gioenumtypes.c          \
@@ -634,52 +654,51 @@ BUILT_SOURCES =           \
 
 EXTRA_DIST +=                  \
        data-to-c.pl            \
-       gio.symbols             \
        gioenumtypes.h.template \
        gioenumtypes.c.template \
        makefile.msc            \
-       abicheck.sh             \
        gio.rc.in               \
        gschema.dtd             \
        gconstructor_as_data.h  \
        gnetworking.h.win32     \
        $(NULL)
 
-BUILT_EXTRA_DIST             \
+BUILT_EXTRA_DIST +=            \
        gio.rc
 
 # This is read by gobject-introspection/misc/ and gtk-doc
 gio-public-headers.txt: Makefile
        $(AM_V_GEN) echo $(gioinclude_HEADERS) $(giowin32include_HEADERS) $(giounixinclude_HEADERS) > $@.tmp && mv $@.tmp $@
 
-CLEANFILES = gdbus-daemon-generated.c gdbus-daemon-generated.h gio-public-headers.txt gconstructor_as_data.h
+CLEANFILES += gdbus-daemon-generated.c gdbus-daemon-generated.h gio-public-headers.txt gconstructor_as_data.h
 
 
-DISTCLEANFILES               \
+DISTCLEANFILES +=              \
        gioenumtypes.h          \
        gioenumtypes.c
 
 all-local: gio-public-headers.txt
 
 gioenumtypes.h: $(gio_headers) gioenumtypes.h.template
-       $(AM_V_GEN) ( top_builddir=`cd $(top_builddir) && pwd`; \
-         cd $(srcdir) && $$top_builddir/gobject/glib-mkenums --template gioenumtypes.h.template $(gio_headers) ) > \
+       $(AM_V_GEN) $(top_builddir)/gobject/glib-mkenums --template $(filter %.template,$^) $(filter-out %.template,$^) > \
            gioenumtypes.h.tmp && mv gioenumtypes.h.tmp gioenumtypes.h
 
 gioenumtypes.c: $(gio_headers) gioenumtypes.c.template
-       $(AM_V_GEN) ( top_builddir=`cd $(top_builddir) && pwd`; \
-         cd $(srcdir) && $$top_builddir/gobject/glib-mkenums --template gioenumtypes.c.template $(gio_headers) ) > \
+       $(AM_V_GEN) $(top_builddir)/gobject/glib-mkenums --template $(filter %.template,$^) $(filter-out %.template,$^) > \
            gioenumtypes.c.tmp && mv gioenumtypes.c.tmp gioenumtypes.c
 
+gio.def: libgio-2.0.la
+       $(AM_V_GEN) dumpbin.exe -exports .libs/libgio-2.0-0.dll | awk 'BEGIN { print "EXPORTS" } / +[[:digit:]]+ +[[:xdigit:]]+ +[[:xdigit:]]+/{ print $$4 }' > gio.def.tmp && mv gio.def.tmp gio.def
+
 gio-2.0.lib: libgio-2.0.la gio.def
-       lib -machine:@LIB_EXE_MACHINE_FLAG@ -name:libgio-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:$(builddir)/gio.def -out:$@
+       $(AM_V_GEN) lib.exe -machine:@LIB_EXE_MACHINE_FLAG@ -name:libgio-2.0-$(LT_CURRENT_MINUS_AGE).dll -def:$(builddir)/gio.def -out:$@
 
 bin_PROGRAMS = gio-querymodules glib-compile-schemas glib-compile-resources gsettings
 
-glib_compile_resources_LDADD = \
-       $(top_builddir)/glib/libglib-2.0.la \
+glib_compile_resources_LDADD = libgio-2.0.la           \
        $(top_builddir)/gobject/libgobject-2.0.la       \
-       libgio-2.0.la
+       $(top_builddir)/glib/libglib-2.0.la             \
+       $(NULL)
 
 glib_compile_resources_SOURCES = \
        gvdb/gvdb-format.h              \
@@ -688,11 +707,10 @@ glib_compile_resources_SOURCES = \
        glib-compile-resources.c
 
 gio_querymodules_SOURCES = gio-querymodules.c
-gio_querymodules_LDADD  = \
-       $(top_builddir)/glib/libglib-2.0.la             \
+gio_querymodules_LDADD  = libgio-2.0.la                \
        $(top_builddir)/gobject/libgobject-2.0.la       \
        $(top_builddir)/gmodule/libgmodule-2.0.la       \
-       libgio-2.0.la                                   \
+       $(top_builddir)/glib/libglib-2.0.la             \
        $(NULL)
 
 gconstructor_as_data.h: $(top_srcdir)/glib/gconstructor.h data-to-c.pl
@@ -706,10 +724,10 @@ glib_compile_schemas_SOURCES = \
        gvdb/gvdb-builder.c             \
        glib-compile-schemas.c
 
-gsettings_LDADD = \
-       $(top_builddir)/glib/libglib-2.0.la             \
+gsettings_LDADD = libgio-2.0.la                        \
        $(top_builddir)/gobject/libgobject-2.0.la       \
-       libgio-2.0.la
+       $(top_builddir)/glib/libglib-2.0.la             \
+       $(NULL)
 gsettings_SOURCES = gsettings-tool.c
 
 schemadir = $(datadir)/glib-2.0/schemas
@@ -720,12 +738,25 @@ dist_schema_DATA = gschema.dtd
 
 bin_PROGRAMS += gdbus
 gdbus_SOURCES = gdbus-tool.c
-gdbus_LDADD = libgio-2.0.la \
-       $(top_builddir)/glib/libglib-2.0.la             \
-       $(top_builddir)/gobject/libgobject-2.0.la
+gdbus_LDADD = libgio-2.0.la                            \
+       $(top_builddir)/gobject/libgobject-2.0.la       \
+       $(top_builddir)/glib/libglib-2.0.la             \
+       $(NULL)
+
+if OS_UNIX
+# ------------------------------------------------------------------------
+# gapplication(1) tool
+bin_PROGRAMS += gapplication
+gapplication_SOURCES = gapplication-tool.c
+gapplication_LDADD = libgio-2.0.la                     \
+       $(top_builddir)/gobject/libgobject-2.0.la       \
+       $(top_builddir)/glib/libglib-2.0.la             \
+       $(NULL)
+endif
 
 completiondir = $(datadir)/bash-completion/completions
 completion_DATA = \
+       completion/gapplication                         \
        completion/gdbus                                \
        completion/gsettings                            \
        completion/gresource
@@ -737,9 +768,9 @@ EXTRA_DIST += $(completion_DATA)
 bin_PROGRAMS += gresource
 gresource_SOURCES = gresource-tool.c
 gresource_CPPFLAGS = $(LIBELF_CFLAGS) $(AM_CPPFLAGS)
-gresource_LDADD = libgio-2.0.la \
-       $(top_builddir)/glib/libglib-2.0.la             \
-       $(top_builddir)/gobject/libgobject-2.0.la \
+gresource_LDADD = libgio-2.0.la                                \
+       $(top_builddir)/gobject/libgobject-2.0.la       \
+       $(top_builddir)/glib/libglib-2.0.la             \
        $(LIBELF_LIBS)
 
 # ------------------------------------------------------------------------