Imported Upstream version 2.74.0
[platform/upstream/glib-networking.git] / tls / tests / meson.build
index 7415f91..4afcc81 100644 (file)
@@ -8,12 +8,8 @@ deps = [
   glib_dep,
   gmodule_dep,
   gobject_dep,
-  gnutls_dep
-]
-
-cflags = [
-  '-DSRCDIR="@0@"'.format(meson.current_source_dir()),
-  '-DTOP_BUILDDIR="@0@"'.format(meson.build_root())
+  gnutls_dep,
+  openssl_dep
 ]
 
 envs = [
@@ -56,6 +52,7 @@ foreach backend: backends
     test_conf = configuration_data()
     test_conf.set('installed_tests_dir', installed_tests_execdir)
     test_conf.set('program', program_name)
+    test_conf.set('environment', '')
 
     if enable_installed_tests
       configure_file(
@@ -66,7 +63,7 @@ foreach backend: backends
       )
     endif
 
-    test_cflags = cflags + [
+    test_cflags = [
       '-DBACKEND="@0@"'.format(backend),
       '-DBACKEND_IS_' + backend.to_upper(),
       '-DSIZEOF_TIME_T=@0@'.format(cc.sizeof('time_t', prefix: '#include <time.h>')),
@@ -87,7 +84,7 @@ foreach backend: backends
     )
 
     test_envs = envs + [
-      'GIO_MODULE_DIR=' + join_paths(meson.build_root(), 'tls', backend),
+      'GIO_MODULE_DIR=' + join_paths(meson.project_build_root(), 'tls', backend),
       'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
       'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir())
     ]