Imported Upstream version 2.14.2
[platform/upstream/fontconfig.git] / test / Makefile.am
index 79bcede..03f7324 100644 (file)
@@ -1,3 +1,26 @@
+# 
+#  test/Makefile.am
+# 
+#  Copyright © 2003 Keith Packard
+# 
+#  Permission to use, copy, modify, distribute, and sell this software and its
+#  documentation for any purpose is hereby granted without fee, provided that
+#  the above copyright notice appear in all copies and that both that
+#  copyright notice and this permission notice appear in supporting
+#  documentation, and that the name of the author(s) not be used in
+#  advertising or publicity pertaining to distribution of the software without
+#  specific, written prior permission.  The authors make no
+#  representations about the suitability of this software for any purpose.  It
+#  is provided "as is" without express or implied warranty.
+# 
+#  THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+#  INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+#  EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+#  CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+#  DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+#  TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+#  PERFORMANCE OF THIS SOFTWARE.
+
 check_SCRIPTS=run-test.sh
 TEST_EXTENSIONS = \
        .sh \
@@ -6,18 +29,26 @@ TEST_EXTENSIONS = \
 AM_TESTS_ENVIRONMENT= \
        src=${srcdir}; export src; \
        EXEEXT=${EXEEXT}; export EXEEXT; \
+       LOG_COMPILER=${LOG_COMPILER} ; export LOG_COMPILER; \
        $(NULL)
 
 BUILT_SOURCES = $(builddir)/out.expected
 
 SH_LOG_COMPILER = sh
+if OS_WIN32
+LOG_COMPILER = ${srcdir}/wrapper-script.sh
+endif
 TESTS=run-test.sh
 
 TESTDATA =                     \
        4x6.pcf                 \
        8x16.pcf                \
        fonts.conf.in           \
+       test-45-generic.json    \
+       test-60-generic.json    \
        test-90-synthetic.json  \
+       test-issue-286.json     \
+       test-style-match.json   \
        $(NULL)
 
 if FREETYPE_PCF_LONG_FAMILY_NAMES
@@ -37,6 +68,11 @@ test_pthread_LDADD = $(top_builddir)/src/libfontconfig.la
 # We don't enable this test by default because it will require config and fonts
 # to meaningfully test anything, and we are not installed yet.
 #TESTS += test-pthread
+
+check_PROGRAMS += test-crbug1004254
+test_crbug1004254_LDADD = $(top_builddir)/src/libfontconfig.la
+# Disabling this for the same reason as above but trying to run in run-test.sh.
+#TESTS += test-crbug1004254
 endif
 check_PROGRAMS += test-bz89617
 test_bz89617_CFLAGS = \
@@ -68,17 +104,13 @@ if ENABLE_JSONC
 check_PROGRAMS += test-conf
 test_conf_CFLAGS = $(JSONC_CFLAGS)
 test_conf_LDADD = $(top_builddir)/src/libfontconfig.la $(JSONC_LIBS)
-TESTS += run-test-conf.sh
 endif
+TESTS += run-test-conf.sh
 
 check_PROGRAMS += test-bz106618
 test_bz106618_LDADD = $(top_builddir)/src/libfontconfig.la
 
-check_PROGRAMS += test-hash
-test_hash_CFLAGS = -I$(top_builddir) -I$(top_builddir)/src $(UUID_CFLAGS)
-test_hash_LDADD = $(UUID_LIBS)
-TESTS += test-hash
-
+if !OS_WIN32
 check_PROGRAMS += test-bz106632
 test_bz106632_CFLAGS =                                 \
        -I$(top_builddir)                               \
@@ -90,9 +122,70 @@ test_bz106632_CFLAGS =                                      \
        $(NULL)
 test_bz106632_LDADD = $(top_builddir)/src/libfontconfig.la
 TESTS += test-bz106632
+endif
 
-EXTRA_DIST=run-test.sh run-test-conf.sh $(TESTDATA) out.expected-long-family-names out.expected-no-long-family-names
+check_PROGRAMS += test-issue107
+test_issue107_LDADD =                                  \
+       $(top_builddir)/src/libfontconfig.la            \
+       $(NULL)
+TESTS += test-issue107
 
-CLEANFILES=out out1 out2 fonts.conf out.expected
+if !ENABLE_SHARED
+if !OS_WIN32
+check_PROGRAMS += test-issue110
+test_issue110_CFLAGS =                                 \
+       -I$(top_builddir)                               \
+       -I$(top_builddir)/src                           \
+       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/src                             \
+       -DHAVE_CONFIG_H                                 \
+       -DFONTCONFIG_PATH='"$(BASECONFIGDIR)"'          \
+       $(NULL)
+test_issue110_LDADD =                                  \
+       $(top_builddir)/src/libfontconfig.la            \
+       $(NULL)
+TESTS += test-issue110
+
+check_PROGRAMS += test-d1f48f11
+test_d1f48f11_CFLAGS =                                 \
+       -I$(top_builddir)                               \
+       -I$(top_builddir)/src                           \
+       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/src                             \
+       -DHAVE_CONFIG_H                                 \
+       -DFONTCONFIG_PATH='"$(BASECONFIGDIR)"'          \
+       $(NULL)
+test_d1f48f11_LDADD =                                  \
+       $(top_builddir)/src/libfontconfig.la            \
+       $(NULL)
+TESTS += test-d1f48f11
+endif
+endif
+
+check_PROGRAMS += test-bz1744377
+test_bz1744377_LDADD = $(top_builddir)/src/libfontconfig.la
+TESTS += test-bz1744377
+
+check_PROGRAMS += test-issue180
+test_issue180_LDADD = $(top_builddir)/src/libfontconfig.la
+TESTS += test-issue180
+
+check_PROGRAMS += test-family-matching
+test_family_matching_LDADD = $(top_builddir)/src/libfontconfig.la
+TESTS += test-family-matching
+
+EXTRA_DIST=run-test.sh run-test-conf.sh wrapper-script.sh $(TESTDATA) out.expected-long-family-names out.expected-no-long-family-names
+
+CLEANFILES =           \
+       fonts.conf      \
+       out             \
+       out1            \
+       out2            \
+       out.expected    \
+       run*.log        \
+       run*.trs        \
+       test*.log       \
+       test*.trs       \
+       $(NULL)
 
 -include $(top_srcdir)/git.mk