Apply smack label on system cache
[platform/upstream/fontconfig.git] / packaging / fontconfig.spec
index f0723ea..1511de7 100644 (file)
@@ -120,6 +120,9 @@ mkdir -p %{TZ_SYS_RO_SHARE}/app_fonts
 # The HOME setting is to avoid problems if HOME hasn't been reset
 if [ -x %{TZ_SYS_BIN}/fc-cache ] && %{TZ_SYS_BIN}/fc-cache --version 2>&1 | grep -q %{version} ; then
 fc-cache -rf --system-only
+chsmack -t %{TZ_SYS_VAR}/cache/fontconfig
+chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig
+chsmack -a User::App::Shared %{TZ_SYS_VAR}/cache/fontconfig/*
 fi
 
 %postun -p /sbin/ldconfig