Set version to 1.3.0 and update coyprights throughout.
[platform/upstream/flac.git] / doc / html / Makefile.am
index 2915829..823b0a9 100644 (file)
@@ -1,5 +1,6 @@
 #  FLAC - Free Lossless Audio Codec
-#  Copyright (C) 2001,2002,2003,2004  Josh Coalson
+#  Copyright (C) 2001-2009  Josh Coalson
+#  Copyright (C) 2011-2013  Xiph.Org Foundation
 #
 #  This file is part the FLAC project.  FLAC is comprised of several
 #  components distributed under difference licenses.  The codec libraries
 #  restrictive of those mentioned above.  See the file COPYING.Xiph in this
 #  distribution.
 
-AUTOMAKE_OPTIONS = foreign
-
 SUBDIRS = ru images
 
 docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/html
 
-doc_DATA =  \
+doc_DATA = \
        changelog.html \
        comparison.html \
+       comparison__chopin_prelude_24.html \
+       comparison__dream_theater_600.html \
+       comparison__eddie_warner_titus.html \
+       comparison__fanfare_de_l_eventail_de_jeanne.html \
+       comparison__gloria_estefan_conga.html \
+       comparison__hand_in_my_pocket.html \
+       comparison__l_sub_raga_sivapriya.html \
+       comparison__laetatus_sum.html \
+       comparison__mummified_in_barbed_wire.html \
+       comparison__prokofiev_pcon3_3.html \
+       comparison__ravel_sq4_4.html \
+       comparison__scarlatti_k42.html \
+       comparison__tool_forty_six_and_2.html \
+       comparison__white_room.html \
+       comparison_all_cpudectime.html \
+       comparison_all_cpuenctime.html \
+       comparison_all_procdectime.html \
+       comparison_all_procenctime.html \
+       comparison_all_ratio.html \
        developers.html \
        documentation.html \
+       documentation_bugs.html \
+       documentation_example_code.html \
+       documentation_format_overview.html \
+       documentation_tasks.html \
+       documentation_tools.html \
+       documentation_tools_flac.html \
+       documentation_tools_metaflac.html \
+       documentation_tools_plugins.html \
        download.html \
        faq.html \
+       favicon.ico \
        features.html \
+       flac.css \
        format.html \
-       goals.html \
        id.html \
        index.html \
+       itunes.html \
        license.html \
        links.html \
-       news.html
+       news.html \
+       ogg_mapping.html
 
-if FLaC__HAS_DOXYGEN
 EXTRA_DIST = $(doc_DATA) api
-else
-EXTRA_DIST = $(doc_DATA)
-endif
 
 if FLaC__HAS_DOXYGEN
 # The install targets don't copy whole directories so we have to
 # handle 'api/' specially:
 install-data-local:
        $(mkinstalldirs) $(DESTDIR)$(docdir)/api
-       (cd api && $(INSTALL_DATA) * $(DESTDIR)$(docdir)/api)
+       (cd $(builddir)/api && $(INSTALL_DATA) * $(DESTDIR)$(docdir)/api)
 uninstall-local:
        rm -rf $(DESTDIR)$(docdir)/api
-maintainer-clean-local:
-       rm -rf api
+distclean-local:
+       -rm -rf api
 endif