packaging: update homepage url
[platform/upstream/elfutils.git] / elfutils.spec
1 # -*- rpm-spec-*-
2 Summary: A collection of utilities and DSOs to handle compiled objects
3 Name: elfutils
4 Version: 0.165
5 Release: 1
6 License: GPLv3+ and (GPLv2+ or LGPLv3+)
7 Group: Development/Tools
8 Source: elfutils-%{version}.tar.bz2
9 Obsoletes: libelf libelf-devel
10 Requires: elfutils-libelf = %{version}-%{release}
11 Requires: glibc >= 2.7
12 Requires: libstdc++
13 Requires: default-yama-scope
14
15 # ExcludeArch: xxx
16
17 BuildRoot: %{_tmppath}/%{name}-root
18 BuildRequires: gcc >= 4.1.2-33
19 BuildRequires: glibc >= 2.7
20 BuildRequires: bison >= 1.875
21 BuildRequires: flex >= 2.5.4a
22 BuildRequires: bzip2
23 BuildRequires: m4
24 BuildRequires: gettext
25 BuildRequires: zlib-devel
26 BuildRequires: bzip2-devel
27 BuildRequires: xz-devel
28 BuildRequires: gcc-c++
29
30 %define _gnu %{nil}
31 %define _programprefix eu-
32
33 %description
34
35 Elfutils is a collection of utilities, including stack (to show
36 backtraces), nm (for listing symbols from object files), size
37 (for listing the section sizes of an object or archive file),
38 strip (for discarding symbols), readelf (to see the raw ELF file
39 structures), elflint (to check for well-formed ELF files) and
40 elfcompress (to compress or decompress ELF sections).
41 Also included are helper libraries which implement DWARF, ELF,
42 and machine-specific ELF handling and process introspection.
43
44 %package devel
45 Summary: Development libraries to handle compiled objects.
46 Group: Development/Tools
47 License: GPLv2+ or LGPLv3+
48 Requires: elfutils = %{version}-%{release}
49 Requires: elfutils-libelf-devel = %{version}-%{release}
50
51 %description devel
52 The elfutils-devel package contains the libraries to create
53 applications for handling compiled objects.  libebl provides some
54 higher-level ELF access functionality.  libdw provides access to
55 the DWARF debugging information.  libasm provides a programmable
56 assembler interface.
57
58 %package devel-static
59 Summary: Static archives to handle compiled objects.
60 Group: Development/Tools
61 License: GPLv2+ or LGPLv3+
62 Requires: elfutils-devel = %{version}-%{release}
63
64 %description devel-static
65 The elfutils-devel-static archive contains the static archives
66 with the code the handle compiled objects.
67
68 %package libelf
69 Summary: Library to read and write ELF files.
70 Group: Development/Tools
71 License: GPLv2+ or LGPLv3+
72
73 %description libelf
74 The elfutils-libelf package provides a DSO which allows reading and
75 writing ELF files on a high level.  Third party programs depend on
76 this package to read internals of ELF files.  The programs of the
77 elfutils package use it also to generate new ELF files.
78
79 %package libelf-devel
80 Summary: Development support for libelf
81 Group: Development/Tools
82 License: GPLv2+ or LGPLv3+
83 Requires: elfutils-libelf = %{version}-%{release}
84 Conflicts: libelf-devel
85
86 %description libelf-devel
87 The elfutils-libelf-devel package contains the libraries to create
88 applications for handling compiled objects.  libelf allows you to
89 access the internals of the ELF object file format, so you can see the
90 different sections of an ELF file.
91
92 %package libelf-devel-static
93 Summary: Static archive of libelf
94 Group: Development/Tools
95 License: GPLv2+ or LGPLv3+
96 Requires: elfutils-libelf-devel = %{version}-%{release}
97 Conflicts: libelf-devel
98
99 %description libelf-devel-static
100 The elfutils-libelf-static package contains the static archive
101 for libelf.
102
103 %package default-yama-scope
104 Summary: Default yama attach scope sysctl setting
105 Group: Development/Tools
106 License: GPLv2+ or LGPLv3+
107 Provides: default-yama-scope
108 BuildArch: noarch
109
110 %description default-yama-scope
111 Yama sysctl setting to enable default attach scope settings
112 enabling programs to use ptrace attach, access to
113 /proc/PID/{mem,personality,stack,syscall}, and the syscalls
114 process_vm_readv and process_vm_writev which are used for
115 interprocess services, communication and introspection
116 (like synchronisation, signaling, debugging, tracing and
117 profiling) of processes.
118
119 %prep
120 %setup -q
121
122 %build
123 %configure --program-prefix=%{_programprefix}
124 make
125
126 %install
127 rm -rf ${RPM_BUILD_ROOT}
128 mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
129
130 %makeinstall
131
132 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
133 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
134
135 # XXX Nuke unpackaged files
136 { cd ${RPM_BUILD_ROOT}
137   rm -f .%{_bindir}/eu-ld
138   rm -f .%{_includedir}/elfutils/libasm.h
139   rm -f .%{_libdir}/libasm.so
140   rm -f .%{_libdir}/libasm.a
141 }
142
143 install -Dm0644 config/10-default-yama-scope.conf ${RPM_BUILD_ROOT}%{_sysctldir}/10-default-yama-scope.conf
144
145 %check
146 make check
147
148 %clean
149 rm -rf ${RPM_BUILD_ROOT}
150
151 %post -p /sbin/ldconfig
152
153 %postun -p /sbin/ldconfig
154
155 %post libelf -p /sbin/ldconfig
156
157 %postun libelf -p /sbin/ldconfig
158
159 %post default-yama-scope
160 %sysctl_apply 10-default-yama-scope.conf
161
162 %files
163 %defattr(-,root,root)
164 %doc COPYING COPYING-GPLV2 COPYING-LGPLV3 README TODO CONTRIBUTING
165 %{_bindir}/eu-elflint
166 %{_bindir}/eu-nm
167 %{_bindir}/eu-readelf
168 %{_bindir}/eu-size
169 %{_bindir}/eu-strip
170 %{_bindir}/eu-findtextrel
171 %{_bindir}/eu-addr2line
172 %{_bindir}/eu-elfcmp
173 %{_bindir}/eu-ranlib
174 %{_bindir}/eu-strings
175 %{_bindir}/eu-objdump
176 %{_bindir}/eu-ar
177 %{_bindir}/eu-unstrip
178 %{_bindir}/eu-make-debug-archive
179 #%{_bindir}/eu-ld
180 %{_bindir}/eu-elfcompress
181 %{_libdir}/libasm-%{version}.so
182 %{_libdir}/libdw-%{version}.so
183 %{_libdir}/libasm.so.*
184 %{_libdir}/libdw.so.*
185 %dir %{_libdir}/elfutils
186 %{_libdir}/elfutils/lib*.so
187
188 %files devel
189 %defattr(-,root,root)
190 %{_includedir}/dwarf.h
191 %dir %{_includedir}/elfutils
192 %{_includedir}/elfutils/elf-knowledge.h
193 %{_includedir}/elfutils/known-dwarf.h
194 #%{_includedir}/elfutils/libasm.h
195 %{_includedir}/elfutils/libebl.h
196 %{_includedir}/elfutils/libdw.h
197 %{_includedir}/elfutils/libdwfl.h
198 %{_includedir}/elfutils/libdwelf.h
199 %{_includedir}/elfutils/version.h
200 %{_libdir}/libebl.a
201 #%{_libdir}/libasm.so
202 %{_libdir}/libdw.so
203 %{_libdir}/pkgconfig/libdw.pc
204
205 %files devel-static
206 %{_libdir}/libdw.a
207 #%{_libdir}/libasm.a
208
209 %files libelf
210 %defattr(-,root,root)
211 %{_libdir}/libelf-%{version}.so
212 %{_libdir}/libelf.so.*
213 %{_datadir}/locale/*/LC_MESSAGES/elfutils.mo
214
215 %files libelf-devel
216 %defattr(-,root,root)
217 %{_includedir}/libelf.h
218 %{_includedir}/gelf.h
219 %{_includedir}/nlist.h
220 %{_includedir}/elfutils/version.h
221 %{_libdir}/libelf.so
222 %{_libdir}/pkgconfig/libelf.pc
223
224 %files libelf-devel-static
225 %{_libdir}/libelf.a
226
227 %files default-yama-scope
228 %config(noreplace) %{_sysctldir}/10-default-yama-scope.conf
229
230 %changelog
231 * Fri Jan  8 2016 Mark Wielaard <mjw@redhat.com> 0.165-1
232 - elfcompress: New utility to compress or decompress ELF sections.
233 - readelf: Add -z,--decompress option.
234 - libelf: Add elf_compress, elf_compress_gnu, elf32_getchdr,
235   elf64_getchdr and gelf_getchdr.
236 - libdwelf: New function dwelf_scn_gnu_compressed_size.
237 - config: Add libelf and libdw pkg-config files.
238 - backends: sparc support for core and live backtraces.
239 - translations: Updated Polish translation.
240
241 * Thu Oct 15 2015 Mark Wielaard <mjw@redhat.com> 0.164-1
242 - strip, unstrip: Handle ELF files with merged strtab/shstrtab
243   tables. Handle missing SHF_INFO_LINK section flags.
244 - libelf: Use int64_t for offsets in libelf.h instead of loff_t.
245 - libdw: dwarf.h Add preliminary DWARF5 DW_LANG_Haskell.
246 - libdwfl: dwfl_standard_find_debuginfo now searches any subdir of
247   the binary path under the debuginfo root when the separate
248   debug file couldn't be found by build-id.
249   dwfl_linux_proc_attach can now be called before any Dwfl_Modules
250   have been reported.
251 - backends: Better sparc and sparc64 support.
252 - translations: Updated Ukrainian translation.
253 - Provide default-yama-scope subpackage.
254
255 * Fri Jun 19 2015 Mark Wielaard <mjw@redhat.com> 0.163-1
256 - Bug fixes only, no new features.
257
258 * Wed Jun 10 2015 Mark Wielaard <mjw@redhat.com> 0.162-1
259 - libdw: Install new header elfutils/known-dwarf.h.
260   dwarf.h Add preliminary DWARF5 constants DW_TAG_atomic_type,
261   DW_LANG_Fortran03, DW_LANG_Fortran08. dwarf_peel_type now also
262   handles DW_TAG_atomic_type.
263 - addr2line: Input addresses are now always interpreted as
264   hexadecimal numbers, never as octal or decimal numbers.
265   New option -a, --addresses to print address before each entry.
266   New option -C, --demangle to show demangled symbols.
267   New option --pretty-print to print all information on one line.
268 - ar: CVE-2014-9447 Directory traversal vulnerability in ar
269   extraction.
270 - backends: x32 support.
271
272 * Thu Dec 18 2014 Mark Wielaard <mjw@redhat.com> 0.161-1
273 - libdw: New function dwarf_peel_type. dwarf_aggregate_size now uses
274   dwarf_peel_type to also provide the sizes of qualified types.
275   dwarf_getmacros will now serve either of .debug_macro and
276   .debug_macinfo transparently.  New interfaces dwarf_getmacros_off,
277   dwarf_macro_getsrcfiles, dwarf_macro_getparamcnt, and
278   dwarf_macro_param are available for more generalized inspection of
279   macros and their parameters.
280   dwarf.h: Add DW_AT_GNU_deleted, DW_AT_noreturn, DW_LANG_C11,
281   DW_LANG_C_plus_plus_11 and DW_LANG_C_plus_plus_14.
282
283 * Mon Aug 25 2014 Mark Wielaard <mjw@redhat.com> 0.160-1
284 - libdw: New functions dwarf_cu_getdwarf, dwarf_cu_die.
285   dwarf.h remove non-existing DW_TAG_mutable_type.
286 - libdwfl: Handle LZMA .ko.xz compressed kernel modules.
287 - unstrip: New option -F, --force to combining files even if some ELF
288   headers don't seem to match.
289 - backends: Handle ARM THUMB functions. Add support for ppc64le ELFv2 abi.
290
291 * Sat May 17 2014 Mark Wielaard <mjw@redhat.com> 0.159-1
292 - stack: New option -d, --debugname to lookup DWARF debuginfo name 
293   for frame.  New option -i, --inlines to show inlined frames 
294   using DWARF debuginfo.
295 - libdwelf: New libdwelf.h header for libdw.so DWARF ELF Low-level 
296   Functions.  New function dwelf_elf_gnu_debuglink, 
297   dwelf_dwarf_gnu_debugaltlink, and dwelf_elf_gnu_build_id.
298 - libdw: Support for DWZ multifile forms DW_FORM_GNU_ref_alt and      
299   DW_FORM_GNU_strp_alt is now enabled by default and no longer        
300   experimental. Added new functions dwarf_getalt and dwarf_setalt       
301   to get or set the alternative debug file used for the alt FORMs.     
302   The dwfl_linux_proc_find_elf callback will now find ELF from       
303   process memory for (deleted) files if the Dwfl has process state     
304   attached.
305 - libdwfl: The dwfl_build_id_find_debuginfo and 
306   dwfl_standard_find_debuginfo functions will now try to 
307   resolve and set the alternative debug file.
308 - backends: Add CFI unwinding for arm. Relies on .debug_frame.        
309   Add arm process initial register state compatible mode to AARCH64. 
310   Add aarch64 native and core unwind support.
311 - other: All separate elfutils-robustify patches have been merged.    
312   CVE-2014-0172 Check overflow before calling malloc to uncompress 
313   data.
314
315 * Fri Jan  3 2014 Mark Wielaard <mjw@redhat.com> 0.158-1
316 - libdwfl: dwfl_core_file_report has new parameter executable.
317   New functions dwfl_module_getsymtab_first_global,
318   dwfl_module_getsym_info and dwfl_module_addrinfo.
319   Added unwinder with type Dwfl_Thread_Callbacks, opaque types
320   Dwfl_Thread and Dwfl_Frame and functions dwfl_attach_state,
321   dwfl_pid, dwfl_thread_dwfl, dwfl_thread_tid, dwfl_frame_thread,
322   dwfl_thread_state_registers, dwfl_thread_state_register_pc,
323   dwfl_getthread_frames, dwfl_getthreads, dwfl_thread_getframes
324   and dwfl_frame_pc.
325 - addr2line: New option -x to show the section an address was found in.
326 - stack: New utility that uses the new unwinder for processes and cores.
327 - backends: Unwinder support for i386, x86_64, s390, s390x, ppc and ppc64.
328   aarch64 support.
329
330 * Mon Sep 30 2013 Mark Wielaard <mjw@redhat.com> 0.157-1
331 - libdw: Add new functions dwarf_getlocations, dwarf_getlocation_attr 
332          and dwarf_getlocation_die.
333 - readelf: Show contents of NT_SIGINFO and NT_FILE core notes.
334 - addr2line: Support -i, --inlines output option.
335 - backends: abi_cfi hook for arm, ppc and s390.
336
337 * Thu Jul 25 2013 Jan Kratochvil <jan.kratochvil@redhat.com> 0.156-1
338 - lib: New macro COMPAT_VERSION_NEWPROTO.
339 - libdw: Handle GNU extension opcodes in dwarf_getlocation.
340 - libdwfl: Fix STB_GLOBAL over STB_WEAK preference in 
341   dwfl_module_addrsym.          Add minisymtab support.          Add 
342   parameter add_p_vaddr to dwfl_report_elf.          Use DT_DEBUG 
343   library search first.
344 - libebl: Handle new core note types in EBL.
345 - backends: Interpret NT_ARM_VFP.           Implement core file 
346   registers parsing for s390/s390x.
347 - readelf: Add --elf-section input option to inspect an embedded ELF 
348   file.          Add -U, --unresolved-address-offsets output control.   
349          Add --debug-dump=decodedline support.          Accept version 
350   8 .gdb_index section format.          Adjust output formatting width. 
351            When highpc is in constant form print it also as address.    
352         Display raw .debug_aranges. Use libdw only for decodedaranges.
353 - elflint: Add __bss_start__ to the list of allowed symbols.
354 - tests: Add configure --enable-valgrind option to run all tests 
355   under valgrind.        Enable automake parallel-tests for make check.
356 - translations: Updated Polish translation.
357 - Updates for Automake 1.13.
358
359 * Fri Aug 24 2012 Mark Wielaard <mjw@redhat.com> 0.155-1
360 - libelf: elf*_xlatetomd now works for cross-endian ELF note data.    
361        elf_getshdr now works consistently on non-mmaped ELF files after 
362           calling elf_cntl(ELF_C_FDREAD).         Implement support for 
363   ar archives with 64-bit symbol table.
364 - libdw: dwarf.h corrected the DW_LANG_ObjC constant name (was 
365   DW_LANG_Objc).        Any existing sources using the old name will 
366   have to be updated.        Add DW_MACRO_GNU .debug_macro type 
367   encodings constants, DW_ATE_UTF        and DW_OP_GNU_parameter_ref to 
368   dwarf.h.        Experimental support for DWZ multifile forms 
369   DW_FORM_GNU_ref_alt        and DW_FORM_GNU_strp_alt.  Disabled by 
370   default.  Use configure        --enable-dwz to test it.
371 - readelf: Add .debug_macro parsing support.          Add .gdb_index 
372   version 7 parsing support.          Recognize DW_OP_GNU_parameter_ref.
373 - backends: Add support for Tilera TILE-Gx processor.
374 - translations: Updated Ukrainian translation.
375
376 * Fri Jun 22 2012 Mark Wielaard <mjw@redhat.com> 0.154-1
377 - libelf: [g]elf[32|64]_offscn() do not match SHT_NOBITS sections at 
378   OFFSET.
379 - libdw: dwarf_highpc function now handles DWARF 4 DW_AT_high_pc 
380   constant form.        Fix bug using dwarf_next_unit to iterate over 
381   .debug_types.
382 - elflint: Now accepts gold linker produced executables.
383 - The license is now GPLv2/LGPLv3+ for the libraries and GPLv3+ for 
384   stand-alone programs. There is now also a formal CONTRIBUTING 
385   document describing how to submit patches.
386
387 * Thu Feb 23 2012 Mark Wielaard <mjw@redhat.com> 0.153-1
388 - libdw: Support reading .zdebug_* DWARF sections compressed via zlib.
389 - libdwfl: Speed up dwfl_module_addrsym.
390 - nm: Support C++ demangling.
391 - ar: Support D modifier for "deterministic output" with no 
392   uid/gid/mtime info.     The U modifier is the inverse.     elfutils 
393   can be configured with the --enable-deterministic-archives     option 
394   to make the D behavior the default when U is not specified.
395 - ranlib: Support -D and -U flags with same meaning.
396 - readelf: Improve output of -wline. Add support for printing SDT elf 
397   notes.          Add printing of .gdb_index section.    Support for 
398   typed DWARF stack, call_site and entry_value.
399 - strip: Add --reloc-debug-sections option.        Improved SHT_GROUP 
400   sections handling.
401
402 * Tue Feb 15 2011  <drepper@gmail.com> 0.152-1
403 - Various build and warning nits fixed for newest GCC and Autoconf.
404 - libdwfl: Yet another prelink-related fix for another regression.
405          Look for Linux kernel images in files named with compression
406   suffixes.
407 - elfcmp: New flag --ignore-build-id to ignore differing build ID
408   bits.         New flag -l/--verbose to print all differences.
409
410 * Wed Jan 12 2011  <drepper@gmail.com> 0.151-1
411 - libdwfl: Fix for more prelink cases with separate debug file.
412 - strip: New flag --strip-sections to remove section headers entirely.
413
414 * Mon Nov 22 2010  <drepper@gmail.com> 0.150-1
415 - libdw: Fix for handling huge .debug_aranges section.
416 - libdwfl: Fix for handling prelinked DSO with separate debug file.
417 - findtextrel: Fix diagnostics to work with usual section ordering.
418 - libebl: i386 backend fix for multi-register integer return value
419   location.
420
421 * Mon Sep 13 2010  <drepper@redhat.com> 0.149-1
422 - libdw: Decode new DW_OP_GNU_implicit_pointer operation;        new
423   function dwarf_getlocation_implicit_pointer.
424 - libdwfl: New function dwfl_dwarf_line.
425 - addr2line: New flag -F/--flags to print more DWARF line information
426   details.
427 - strip: -g recognizes .gdb_index as a debugging section.
428
429 * Mon Jun 28 2010  <drepper@redhat.com> 0.148-1
430 - libdw: Accept DWARF 4 format: new functions dwarf_next_unit,
431   dwarf_offdie_types.        New functions dwarf_lineisa,
432   dwarf_linediscriminator, dwarf_lineop_index.
433 - libdwfl: Fixes in core-file handling, support cores from PIEs.
434          When working from build IDs, don't open a named file that
435   mismatches.
436 - readelf: Handle DWARF 4 formats.
437
438 * Mon May  3 2010 Ulrich Drepper <drepper@redhat.com> 0.147-1
439 - libdw: Fixes in CFI handling, best possible handling of bogus CFA
440   ops.
441 - libdwfl: Ignore R_*_NONE relocs, works around old (binutils) ld -r
442   bugs.
443
444 * Wed Apr 21 2010  <drepper@redhat.com> 0.146-1
445 - libdwfl: New function dwfl_core_file_report.
446
447 * Tue Feb 23 2010 Ulrich Drepper <drepper@redhat.com> 0.145-1
448 - Fix build with --disable-dependency-tracking.
449 - Fix build with most recent glibc headers.
450 - libelf: More robust to bogus section headers.
451 - libdw: Fix CFI decoding.
452 - libdwfl: Fix address bias returned by CFI accessors.   Fix core
453   file module layout identification.
454 - readelf: Fix CFI decoding.
455
456 * Thu Jan 14 2010  <drepper@redhat.com> 0.144-1
457 - libelf: New function elf_getphdrnum.  Now support using more than
458   65536 program headers in a file.
459 - libdw: New function dwarf_aggregate_size for computing (constant)
460   type        sizes, including array_type cases with nontrivial
461   calculation.
462 - readelf: Don't give errors for missing info under -a.
463   Handle Linux "VMCOREINFO" notes under -n.
464
465 * Mon Sep 21 2009  <drepper@redhat.com> 0.143-1
466 - libdw: Various convenience functions for individual attributes now
467   use dwarf_attr_integrate to look up indirect inherited
468   attributes.  Location expression handling now supports
469   DW_OP_implicit_value.
470 - libdwfl: Support automatic decompression of files in XZ format,
471   and of Linux kernel images made with bzip2 or LZMA (as well
472   as gzip).
473
474 * Mon Jun 29 2009  <drepper@redhat.com> 0.142-1
475 - libelf: Add elf_getshdrnum alias for elf_getshnum and elf_getshdrstrndx alias
476   for elf_getshstrndx and deprecate original names.  Sun screwed up
477   their implementation and asked for a solution.
478 - libebl: Add support for STB_GNU_UNIQUE.
479 - elflint: Add support for STB_GNU_UNIQUE.
480 - readelf: Add -N option, speeds up DWARF printing without address->name lookups.
481 - libdw: Add support for decoding DWARF CFI into location description form.
482   Handle some new DWARF 3 expression operations previously omitted.
483   Basic handling of some new encodings slated for DWARF
484
485 * Thu Apr 23 2009 Ulrich Drepper <drepper@redhat.com> 0.141-1
486 - libebl: sparc backend fixes;  some more arm backend support
487 - libdwfl: fix dwfl_module_build_id for prelinked DSO case;
488   fixes in core file support;    dwfl_module_getsym interface
489   improved for non-address symbols
490 - strip: fix infinite loop on strange inputs with -f
491 - addr2line: take -j/--section=NAME option for binutils compatibility
492            (same effect as '(NAME)0x123' syntax already supported)
493
494 * Mon Feb 16 2009 Ulrich Drepper <drepper@redhat.com> 0.140-1
495 - libelf: Fix regression in creation of section header
496 - libdwfl: Less strict behavior if DWARF reader ist just used to
497   display data
498
499 * Thu Jan 22 2009 Ulrich Drepper <drepper@redhat.com> 0.139-1
500 - libcpu: Add Intel SSE4 disassembler support
501 - readelf: Implement call frame information and exception handling
502   dumping.          Add -e option.  Enable it implicitly for -a.
503 - elflint: Check PT_GNU_EH_FRAME program header entry.
504 - libdwfl: Support automatic gzip/bzip2 decompression of ELF files.
505
506 * Wed Dec 31 2008 Roland McGrath <roland@redhat.com> 0.138-1
507 - Install <elfutils/version.h> header file for applications to use in
508   source version compatibility checks.
509 - libebl: backend fixes for i386 TLS relocs; backend support for
510   NT_386_IOPERM
511 - libcpu: disassembler fixes
512 - libdwfl: bug fixes
513 - libelf: bug fixes
514 - nm: bug fixes for handling corrupt input files
515
516 * Tue Aug 26 2008 Ulrich Drepper <drepper@redhat.com> 0.137-1
517 - Minor fixes for unreleased 0.136 release.
518
519 * Mon Aug 25 2008 Ulrich Drepper <drepper@redhat.com> 0.136-1
520 - libdwfl: bug fixes; new segment interfaces;    all the libdwfl-based
521  tools now support --core=COREFILE option
522
523 * Mon May 12 2008 Ulrich Drepper <drepper@redhat.com> 0.135-1
524 - libdwfl: bug fixes
525 - strip: changed handling of ET_REL files wrt symbol tables and relocs
526
527 * Tue Apr  8 2008 Ulrich Drepper <drepper@redhat.com> 0.134-1
528 - elflint: backend improvements for sparc, alpha
529 - libdwfl, libelf: bug fixes
530
531 * Sat Mar  1 2008 Ulrich Drepper <drepper@redhat.com> 0.133-1
532 - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
533 - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
534 - libdwfl: bug fixes and optimization in relocation handling
535 - elfcmp: bug fix for non-allocated section handling
536 - ld: implement newer features of binutils linker.
537
538 * Mon Jan 21 2008 Ulrich Drepper <drepper@redhat.com> 0.132-1
539 - libcpu: Implement x86 and x86-64 disassembler.
540 - libasm: Add interface for disassembler.
541 - all programs: add debugging of branch prediction.
542 - libelf: new function elf_scnshndx.
543
544 * Sun Nov 11 2007 Ulrich Drepper <drepper@redhat.com> 0.131-1
545 - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now depreca
546 ted;       bug fixes for oddly-formatted DWARF
547 - libdwfl: bug fixes in offline archive support, symbol table handling;
548          apply partial relocations for dwfl_module_address_section on
549 ET_REL
550 - libebl: powerpc backend support for Altivec registers
551
552 * Mon Oct 15 2007 Ulrich Drepper <drepper@redhat.com> 0.130-1
553 - readelf: -p option can take an argument like -x for one section,
554          or no argument (as before) for all SHF_STRINGS sections;
555          new option --archive-index (or -c);     improved -n output fo
556 r core files, on many machines
557 - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
558         new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
559 - readelf, elflint: handle SHT_NOTE sections without requiring phdrs
560 - elflint: stricter checks on debug sections
561 - libdwfl: new functions dwfl_build_id_find_elf, dwfl_build_id_find_debu
562 ginfo,   dwfl_module_build_id, dwfl_module_report_build_id;      suppo
563 rt dynamic symbol tables found via phdrs;        dwfl_standard_find_de
564 buginfo now uses build IDs when available
565 - unstrip: new option --list (or -n)
566 - libebl: backend improvements for sparc, alpha, powerpc
567
568 * Tue Aug 14 2007 Ulrich Drepper <drepper@redhat.com> 0.129-1
569 - readelf: new options --hex-dump (or -x), --strings (or -p)
570 - addr2line: new option --symbols (or -S)
571
572 * Wed Apr 18 2007 Ulrich Drepper <drepper@redhat.com> 0.127-1
573 - libdw: new function dwarf_getsrcdirs
574 - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
575          dwfl_module_address_section
576
577 * Mon Feb  5 2007 Ulrich Drepper <drepper@redhat.com> 0.126-1
578 - new program: ar
579
580 * Mon Dec 18 2006 Ulrich Drepper <drepper@redhat.com> 0.125-1
581 - elflint: Compare DT_GNU_HASH tests.
582 - move archives into -static RPMs
583 - libelf, elflint: better support for core file handling
584
585 * Tue Oct 10 2006 Ulrich Drepper <drepper@redhat.com> 0.124-1
586 - libebl: sparc backend support for return value location
587 - libebl, libdwfl: backend register name support extended with more info
588 - libelf, libdw: bug fixes for unaligned accesses on machines that care
589 - readelf, elflint: trivial bugs fixed
590
591 * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
592 - libebl: Backend build fixes, thanks to Stepan Kasal.
593 - libebl: ia64 backend support for register names, return value location
594 - libdwfl: Handle truncated linux kernel module section names.
595 - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
596 - elflint: Fix checks to permit --hash-style=gnu format.
597
598 * Wed Jul 12 2006 Ulrich Drepper <drepper@redhat.com> 0.122-1
599 - libebl: add function to test for relative relocation
600 - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
601 - elflint, readelf: add support for DT_GNU_HASHlibelf: add elf_gnu_hash
602 - elflint, readelf: add support for 64-bit SysV-style hash tables
603 - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
604
605 * Wed Jun 14 2006  <drepper@redhat.com> 0.121-1
606 - libelf: bug fixes for rewriting existing files when using mmap.
607 - make all installed headers usable in C++ code.
608 - readelf: better output format.
609 - elflint: fix tests of dynamic section content.
610 - ld: Implement --as-needed, --execstack, PT_GNU_STACK.  Many small patc
611 hes.
612 - libdw, libdwfl: handle files without aranges info.
613
614 * Tue Apr  4 2006 Ulrich Drepper <drepper@redhat.com> 0.120-1
615 - Bug fixes.
616 - dwarf.h updated for DWARF 3.0 final specification.
617 - libdwfl: New function dwfl_version.
618 - The license is now GPL for most files.  The libelf, libebl, libdw,and
619 libdwfl libraries have additional exceptions.  Add reference toOIN.
620
621 * Thu Jan 12 2006 Roland McGrath <roland@redhat.com> 0.119-1
622 - elflint: more tests.
623 - libdwfl: New function dwfl_module_register_names.
624 - libebl: New backend hook for register names.
625
626 * Tue Dec  6 2005 Ulrich Drepper <drepper@redhat.com> 0.118-1
627 - elflint: more tests.
628 - libdwfl: New function dwfl_module_register_names.
629 - libebl: New backend hook for register names.
630
631 * Thu Nov 17 2005 Ulrich Drepper <drepper@redhat.com> 0.117-1
632 - libdwfl: New function dwfl_module_return_value_location.
633 - libebl: Backend improvements for several CPUs.
634
635 * Mon Oct 31 2005 Ulrich Drepper <drepper@redhat.com> 0.116-1
636 - libdw: New functions dwarf_ranges, dwarf_entrypc, dwarf_diecu,       d
637 warf_entry_breakpoints.  Removed Dwarf_Func type and functions       d
638 warf_func_name, dwarf_func_lowpc, dwarf_func_highpc,       dwarf_func_
639 entrypc, dwarf_func_die; dwarf_getfuncs callback now uses       Dwarf_
640 Die, and dwarf_func_file, dwarf_func_line, dwarf_func_col       replac
641 ed by dwarf_decl_file, dwarf_decl_line, dwarf_decl_column;       dwarf
642 _func_inline, dwarf_func_inline_instances now take Dwarf_Die.       Ty
643 pe Dwarf_Loc renamed to Dwarf_Op; dwarf_getloclist,       dwarf_addrlo
644 clists renamed dwarf_getlocation, dwarf_getlocation_addr.
645
646 * Fri Sep  2 2005 Ulrich Drepper <drepper@redhat.com> 0.115-1
647 - libelf: speed-ups of non-mmap reading.
648 - strings: New program.
649 - Implement --enable-gcov option for configure.
650 - libdw: New function dwarf_getscopes_die.
651
652 * Wed Aug 24 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
653 - libelf: new function elf_getaroff
654 - libdw: Added dwarf_func_die, dwarf_func_inline, dwarf_func_inline_inst
655 ances.
656 - libdwfl: New functions dwfl_report_offline, dwfl_offline_section_addre
657 ss,      dwfl_linux_kernel_report_offline.
658 - ranlib: new program
659
660 * Mon Aug 15 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
661 - libelf: new function elf_getaroff
662 - ranlib: new program
663
664 * Wed Aug 10 2005 Ulrich Drepper <@redhat.com> 0.113-1
665 - elflint: relax a bit. Allow version definitions for defined symbols ag
666 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
667 sectionto have STRINGS and MERGE flag set.
668 - strip: add some more compatibility with binutils.
669
670 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
671 - elflint: relax a bit. Allow version definitions for defined symbols ag
672 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
673 sectionto have STRINGS and MERGE flag set.
674
675 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
676 - elflint: relax a bit. Allow version definitions for defined symbols ag
677 ainstDSO versions also for symbols in nobits sections.
678
679 * Fri Aug  5 2005 Ulrich Drepper <@redhat.com> 0.112-1
680 - elfcmp: some more relaxation.
681 - elflint: many more tests, especially regarding to symbol versioning.
682 - libelf: Add elfXX_offscn and gelf_offscn.
683 - libasm: asm_begin interface changes.
684 - libebl: Add three new interfaces to directly access machine, class, an
685 ddata encoding information.
686 - objdump: New program.  Just the beginning.
687
688 * Thu Jul 28 2005 Ulrich Drepper <@redhat.com> 0.111-1
689 - libdw: now contains all of libdwfl.  The latter is not installed anymore.
690 - elfcmp: little usability tweak, name and index of differing section is
691  printed.
692
693 * Sun Jul 24 2005 Ulrich Drepper <@redhat.com> 0.110-1
694 - libelf: fix a numbe rof problems with elf_update
695 - elfcmp: fix a few bugs.  Compare gaps.
696 - Fix a few PLT problems and mudflap build issues.
697 - libebl: Don't expose Ebl structure definition in libebl.h.  It's now p
698 rivate.
699
700 * Thu Jul 21 2005 Ulrich Drepper <@redhat.com> 0.109-1
701 - libebl: Check for matching modules.
702 - elflint: Check that copy relocations only happen for OBJECT or NOTYPE
703 symbols.
704 - elfcmp: New program.
705 - libdwfl: New library.
706
707 * Mon May  9 2005 Ulrich Drepper <@redhat.com> 0.108-1
708 - strip: fix bug introduced in last change
709 - libdw: records returned by dwarf_getsrclines are now sorted by address
710
711 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.108-1
712 - strip: fix bug introduced in last change
713
714 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.107-1
715 - readelf: improve DWARF output format
716 - strip: support Linux kernel modules
717
718 * Fri Apr 29 2005 Ulrich Drepper <drepper@redhat.com> 0.107-1
719 - readelf: improve DWARF output format
720
721 * Mon Apr  4 2005 Ulrich Drepper <drepper@redhat.com> 0.106-1
722 - libdw: Updated dwarf.h from DWARF3 speclibdw: add new funtions dwarf_f
723 unc_entrypc, dwarf_func_file, dwarf_func_line,dwarf_func_col, dwarf_ge
724 tsrc_file
725
726 * Fri Apr  1 2005 Ulrich Drepper <drepper@redhat.com> 0.105-1
727 - addr2line: New program
728 - libdw: add new functions: dwarf_addrdie, dwarf_macro_*, dwarf_getfuncs
729 ,dwarf_func_*.
730 - findtextrel: use dwarf_addrdie
731
732 * Mon Mar 28 2005 Ulrich Drepper <drepper@redhat.com> 0.104-1
733 - findtextrel: New program.
734
735 * Mon Mar 21 2005 Ulrich Drepper <drepper@redhat.com> 0.103-1
736 - libdw: Fix using libdw.h with gcc < 4 and C++ code.  Compiler bug.
737
738 * Tue Feb 22 2005 Ulrich Drepper <drepper@redhat.com> 0.102-1
739 - More Makefile and spec file cleanups.
740
741 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
742 - upgrade to 0.94
743
744 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
745 - upgrade to 0.93
746
747 * Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
748 - full version
749 - macroized spec file for GPL or OSL builds
750 - include only libelf under GPL plus wrapper scripts
751
752 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
753 - macroized spec file for GPL or OSL builds
754
755 * Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
756 - split elfutils-devel into two packages.
757
758 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
759 - include only libelf under GPL plus wrapper scripts
760
761 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
762 - readelf, not readline, in %%description (#111214).
763
764 * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
765 - update to 0.89 (fix eu-strip)
766
767 * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
768 - update to 0.86 (fix eu-strip on s390x/alpha)
769 - libebl is an archive now; remove references to DSO
770
771 * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
772 - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
773
774 * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
775 - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
776
777 * Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
778 - upgrade to 0.82 (strip tests fixed on big-endian).
779
780 * Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
781 - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
782
783 * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
784 - upgrade to 0.80 (debugedit changes for kernel in progress).
785
786 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
787 - rebuilt
788
789 * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
790 - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
791
792 * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
793 - upgrade to 0.78 (libdwarf bugfix, libdw additions).
794
795 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
796 - debuginfo rebuild
797
798 * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
799 - use the correct way of identifying the section via the sh_info link.
800
801 * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
802 - update to 0.75 (eu-strip -g fix)
803
804 * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
805 - update to 0.74 (fix for writing with some non-dirty sections)
806
807 * Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
808 - another -0.73 update (with sparc fixes).
809 - do "make check" in %%check, not %%install, section.
810
811 * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
812 - update to 0.73 (with s390 fixes).
813
814 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
815 - rebuilt
816
817 * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
818 - fix arguments to gelf_getsymshndx and elf_getshstrndx
819 - fix other warnings
820 - reenable checks on s390x
821
822 * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
823 - temporarily disable checks on s390x, until someone has
824   time to look at it
825
826 * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
827 - update to 0.72
828
829 * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
830 - update to 0.71
831
832 * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
833 - update to 0.69.
834 - add "make check" and segfault avoidance patch.
835 - elfutils-libelf needs to run ldconfig.
836
837 * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
838 - update to 0.68.
839
840 * Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
841 - update to 0.67.
842
843 * Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
844 - update to 0.65.
845
846 * Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
847 - update to 0.64.
848
849 * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
850 - split packages further into elfutils-libelf
851
852 * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
853 - update to 0.63.
854
855 * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
856 - Adjust for dropping libtool
857
858 * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
859 - update to 0.59
860
861 * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
862 - update to 0.56
863
864 * Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
865 - update to 0.54
866
867 * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
868 - update to 0.53
869 - drop x86_64 hack, ICE fixed in gcc-3.2-11.
870
871 * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
872 - get beehive to punch a rhpkg generated package.
873
874 * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
875 - build in 8.0.1.
876 - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
877
878 * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
879 - Add libelf-devel to conflicts for elfutils-devel
880
881 * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
882 - Split into runtime and devel package
883
884 * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
885 - integrate into official sources
886
887 * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
888 - Swaddle.