Apply ASLR to curl command tool
[platform/upstream/curl.git] / src / Makefile.am
index 19bab68..fb97da2 100644 (file)
@@ -57,7 +57,9 @@ include Makefile.inc
 curl_SOURCES = $(CURL_FILES)
 
 # This might hold -Werror
-CFLAGS += @CURL_CFLAG_EXTRAS@
+# Enable Position Independent Executable flag
+CFLAGS += @CURL_CFLAG_EXTRAS@ -fPIE
+LDFLAGS += -pie
 
 # Prevent LIBS from being used for all link targets
 LIBS = $(BLANK_AT_MAKETIME)