ARM build support
[platform/upstream/chromium-browser.git] / packaging / chromium.spec
index fa9412f..2947897 100644 (file)
@@ -101,6 +101,13 @@ export CFLAGS=`echo $CFLAGS | sed s,-g,,g`
 export CXXFLAGS=`echo $CXXFLAGS | sed s,-g,,g`
 %endif
 
+# Copied from Crosswalk
+%ifarch %{arm}
+export CFLAGS=`echo $CFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
+export CXXFLAGS=`echo $CXXFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
+export FFLAGS=`echo $FFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
+%endif
+
 # Building the RPM in the GBS chroot fails with errors such as
 #   /usr/lib/gcc/i586-tizen-linux/4.7/../../../../i586-tizen-linux/bin/ld:
 #       failed to set dynamic section sizes: Memory exhausted
@@ -172,6 +179,7 @@ export GYP_GENERATORS=ninja
 %endif
 %ifarch %{arm}
 -Dtarget_arch=arm \
+-Dsysroot=  \
 %endif
 -Duse_alsa=0 \
 -Duse_gnome_keyring=0 \