Fix gbs packaging problem and disable manifest file for cross toolchain.
[platform/upstream/binutils.git] / packaging / cross-arm-binutils.spec
index 1629f5a..6195437 100644 (file)
@@ -45,26 +45,13 @@ Release:        0
 #
 #
 Url:            http://www.gnu.org/software/binutils/
-%define binutils_version %(echo %version | sed 's/\\.[0-9]\\{8\\}$//')
+#%define binutils_version %(echo %version | sed 's/\\.[0-9]\\{8\\}$//')
 Summary:        GNU Binutils
 License:        GFDL-1.3 and GPL-3.0+
 Group:          Development/Tools/Building
-Source:         binutils-%{binutils_version}.tar.bz2
+Source:         binutils-%{version}.tar.bz2
 Source1:        pre_checkin.sh
 Source3:        baselibs.conf
-# Patches auto-generated by git-buildpackage:
-Patch0:     0001-skip-rpaths.patch
-Patch1:     0002-x86-64-biarch.patch
-Patch2:     0003-unit-at-a-time.patch
-Patch3:     0004-ld-dtags.patch
-Patch4:     0005-ld-relro.patch
-Patch5:     0006-testsuite.patch
-Patch6:     0007-enable-targets-gold.patch
-Patch7:     0008-use-hashtype-both-by-default.patch
-Patch8:     0009-build-as-needed.patch
-Patch9:     0010-fixup-testcase-perturb.patch
-Patch10:    0011-gold-depend-on-opcodes.patch
-Patch11:    0012-bso12451.patch
 
 %description
 C compiler utilities: ar, as, gprof, ld, nm, objcopy, objdump, ranlib,
@@ -110,31 +97,7 @@ binutils.
 
 %prep
 echo "make check will return with %{make_check_handling} in case of testsuite failures."
-%setup -q -n binutils-%{binutils_version}
-# 0001-skip-rpaths.patch
-%patch0 -p1
-# 0002-x86-64-biarch.patch
-%patch1 -p1
-# 0003-unit-at-a-time.patch
-%patch2 -p1
-# 0004-ld-dtags.patch
-%patch3 -p1
-# 0005-ld-relro.patch
-%patch4 -p1
-# 0006-testsuite.patch
-%patch5 -p1
-# 0007-enable-targets-gold.patch
-%patch6 -p1
-# 0008-use-hashtype-both-by-default.patch
-%patch7 -p1
-# 0009-build-as-needed.patch
-%patch8 -p1
-# 0010-fixup-testcase-perturb.patch
-%patch9 -p1
-# 0011-gold-depend-on-opcodes.patch
-%patch10 -p1
-# 0012-bso12451.patch
-%patch11 -p1
+%setup -q
 
 sed -i -e '/BFD_VERSION_DATE/s/$/-%(echo %release | sed 's/\.[0-9]*$//')/' bfd/version.h
 %build