Merge branch 'upstream/2.26.1' into tizen
[platform/upstream/at-spi2-core.git] / test / Makefile.am
index d01d290..e99c237 100644 (file)
@@ -1,47 +1,19 @@
-NULL=
+LDADD = $(top_builddir)/atspi/libatspi.la
 
-noinst_PROGRAMS = test-simple at app simple-at stress-test keysynth-demo key-listener-test event-listener-test window-listener-test screen-review-test keypad-test keysynth-test login-helper-client-test login-helper-server-test
+bin_PROGRAMS = at_spi2_tool
+at_spi2_tool_SOURCES = at_spi2_tool.c
+at_spi2_tool_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir) -I$(top_builddir)/atspi
+at_spi2_tool_CFLAGS = $(GIO_CFLAGS) $(GLIB_CFLAGS) --std=c99 -Wall -fPIE $(GOBJ_LIBS) $(DBUS_CFLAGS)
+at_spi2_tool_LDFLAGS = $(GIO_LIBS) -pie
 
-login_helper_client_test_SOURCES = login-helper-client-test.c
 
-login_helper_server_test_SOURCES = login-helper-server-test.c
+noinst_PROGRAMS = memory
+memory_SOURCES = memory.c
+memory_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir) -I$(top_builddir)/atspi
+memory_CFLAGS = $(GLIB_CFLAGS)         $(GOBJ_LIBS) $(DBUS_CFLAGS)
+memory_LDFLAGS =
 
-keysynth_test_SOURCES = keysynth-test.c
 
-stress_test_SOURCES = stress-test.c
-
-window_listener_test_SOURCES = window-listener-test.c
-
-keypad_test_SOURCES = keypad-test.c
-
-key_listener_test_SOURCES = key-listener-test.c
-
-event_listener_test_SOURCES = event-listener-test.c
-
-screen_review_test_SOURCES = screen-review-test.c
-
-at_SOURCES = at.c 
-
-app_SOURCES = app.c
-
-simple_at_SOURCES = simple-at.c 
-
-keysynth_demo_SOURCES = keysynth-demo.c 
-
-test_simple_SOURCES = test-simple.c 
-
-DEBUG_CFLAGS=-DSPI_DEBUG
-
-INCLUDES = -I$(top_srcdir)           \
-           -I$(top_builddir)         \
-          $(TESTS_CFLAGS)           \
-          $(DEBUG_CFLAGS)
-
-LDADD = ../libspi/libspi.la ../cspi/libcspi.la ../login-helper/libloginhelper.la $(TESTS_LIBS) $(X_LIBS) $(XINPUT_LIBS)
-
-TESTS = test-simple
-
-TESTS_ENVIRONMENT =                                    \
-       LD_LIBRARY_PATH=$(top_builddir)/libspi/.libs/:$(top_builddir)/cspi/.libs/       \
-       PATH=$(top_builddir)/registryd/.libs
+-include $(top_srcdir)/git.mk
 
+EXTRA_DIST = meson.build