Do not check the state of handler (common).
[platform/framework/web/livebox-viewer.git] / packaging / liblivebox-viewer.spec
index dcefc38..1ea6f66 100644 (file)
@@ -1,10 +1,11 @@
 Name: liblivebox-viewer
-Summary: Library for developing the application.
-Version: 0.13.7
+Summary: Library for developing the application
+Version: 0.20.6
 Release: 1
 Group: HomeTF/Livebox
-License: Flora License
+License: Flora
 Source0: %{name}-%{version}.tar.gz
+Source1001: %{name}.manifest
 BuildRequires: cmake, gettext-tools, coreutils
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(aul)
@@ -22,7 +23,7 @@ BuildRequires: pkgconfig(vconf)
 API for creating a new instance of the livebox and managing its life-cycle.
 
 %package devel
-Summary: Header and package configuration files for the livebox viewer development.
+Summary: Header and package configuration files for the livebox viewer development
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
 
@@ -31,8 +32,20 @@ Livebox viewer development library (dev)
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
+%if 0%{?sec_build_binary_debug_enable}
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
+export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+%endif
+
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
+export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
+export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
+%endif
 %cmake .
 make %{?jobs:-j%jobs}
 
@@ -44,15 +57,15 @@ mkdir -p %{buildroot}/%{_datarootdir}/license
 %post
 
 %files -n liblivebox-viewer
-%manifest liblivebox-viewer.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/*.so*
 %{_datarootdir}/license/*
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_includedir}/livebox-viewer/livebox.h
-%{_datarootdir}/doc/livebox-viewer/livebox-viewer_PG.h
 %{_libdir}/pkgconfig/*.pc
 
 # End of a file