Upstream version 7.36.149.0
[platform/framework/web/crosswalk.git] / src / third_party / tlslite / setup.py
old mode 100644 (file)
new mode 100755 (executable)
index e3417c4..51ef011
@@ -1,26 +1,16 @@
 #!/usr/bin/env python
 
-import sys
-from distutils.core import setup, Extension
+# Author: Trevor Perrin
+# See the LICENSE file for legal information regarding use of this file.
 
-if sys.version_info < (2, 2):
-    raise AssertionError("Python 2.2 or later required")
-
-if sys.platform == "win32":
-    ext = Extension("tlslite.utils.win32prng",
-                    sources=["tlslite/utils/win32prng.c"],
-                    libraries=["advapi32"])
-    exts = [ext]
-else:
-    exts = None
+from distutils.core import setup
 
 setup(name="tlslite",
-      version="0.3.8",
+      version="0.4.6",
       author="Trevor Perrin",
-      author_email="trevp@trevp.net",
+      author_email="tlslite@trevp.net",
       url="http://trevp.net/tlslite/",
-      description="tlslite implements SSL and TLS with SRP, shared-keys, cryptoID, or X.509 authentication.",
-      license="public domain",
+      description="tlslite implements SSL and TLS.",
+      license="public domain and BSD",
       scripts=["scripts/tls.py", "scripts/tlsdb.py"],
-      packages=["tlslite", "tlslite.utils", "tlslite.integration"],
-      ext_modules=exts)
+      packages=["tlslite", "tlslite.utils", "tlslite.integration"],)