add pkgconfig and refine spec
[platform/framework/native/shell.git] / src / core / CMakeLists.txt
index 3802b83..c52328e 100644 (file)
@@ -4,23 +4,26 @@ INCLUDE_DIRECTORIES(
        ${CMAKE_SOURCE_DIR}/inc
        ${CMAKE_SOURCE_DIR}/src/inc
        ${CMAKE_SOURCE_DIR}/src/core
-       /usr/include/chromium
-       /usr/include/osp
-       /usr/include/osp/app
-       /usr/include/osp/base
-       /usr/include/osp/io
-       /usr/include/osp/security
        /usr/include/osp/graphics
-       
-       /usr/include/appfw
-       /usr/include/notification
-       /usr/include/shortcut
-       /usr/include/vconf
-       /usr/include/badge
-       /usr/include/glib-2.0
-       /usr/lib/glib-2.0/include
 )
 
+INCLUDE(FindPkgConfig)
+pkg_check_modules(corepkgs REQUIRED
+       capi-appfw-application
+       capi-appfw-app-manager
+       badge
+       chromium
+       glib-2.0
+       notification
+       osp-appfw
+       shortcut
+       vconf
+)
+
+FOREACH(flag ${corepkgs_CFLAGS})
+       SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+ENDFOREACH(flag)
+
 SET (${this_target}_SOURCE_FILES
        FShellLockManager.cpp
        FShellNotificationManager.cpp
@@ -51,15 +54,8 @@ ADD_LIBRARY (${this_target} SHARED ${${this_target}_SOURCE_FILES})
 SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined -Wl,--as-needed")
 
 TARGET_LINK_LIBRARIES(${this_target} "-lpthread" )
-TARGET_LINK_LIBRARIES(${this_target} "-lchromium" )
-TARGET_LINK_LIBRARIES(${this_target} "-L/usr/lib/osp -losp-appfw" )
 TARGET_LINK_LIBRARIES(${this_target} "-losp-uifw" )
-TARGET_LINK_LIBRARIES(${this_target} "-lcapi-appfw-application" )
-TARGET_LINK_LIBRARIES(${this_target} "-lcapi-appfw-app-manager" )
-TARGET_LINK_LIBRARIES(${this_target} "-lnotification" )
-TARGET_LINK_LIBRARIES(${this_target} "-lshortcut" )
-TARGET_LINK_LIBRARIES(${this_target} "-lvconf" )
-TARGET_LINK_LIBRARIES(${this_target} "-lbadge" )
+TARGET_LINK_LIBRARIES(${this_target} ${corepkgs_LDFLAGS})
 
 SET_TARGET_PROPERTIES(${this_target}
        PROPERTIES