Merge "Update deprecated libprivilege-control API functions." into tizen
[platform/framework/native/appfw.git] / src / CMakeLists.txt
index 81d2955..161d6a1 100644 (file)
@@ -15,7 +15,6 @@ pkg_check_modules(pkgs REQUIRED
        ecore
        glib-2.0
        haptic
-       badge
        icu-i18n
        iniparser
        libpcre
@@ -41,6 +40,7 @@ pkg_check_modules(pkgs REQUIRED
        capi-system-system-settings
        capi-system-info
        security-server
+       libprivilege-control
 )
 
 FOREACH(flag ${pkgs_CFLAGS})
@@ -58,6 +58,5 @@ ADD_SUBDIRECTORY(system)
 ADD_SUBDIRECTORY(text)
 ADD_SUBDIRECTORY(appfw)
 ADD_SUBDIRECTORY(osp-string)
-ADD_SUBDIRECTORY(server osp-appfw-server)
-ADD_SUBDIRECTORY(system-server osp-system-server)
-
+ADD_SUBDIRECTORY(server)
+ADD_SUBDIRECTORY(server/system osp-system-server)