Package version up to 4.1.9
[platform/core/uifw/libtbm.git] / packaging / libtbm.spec
index cc80474..8a42379 100644 (file)
@@ -10,7 +10,7 @@
 %define _tmpfilesdir /usr/lib/tmpfiles.d
 
 Name:           libtbm
-Version:        3.3.15
+Version:        4.1.9
 Release:        1
 License:        MIT
 Summary:        The library for Tizen Buffer Manager
@@ -27,6 +27,7 @@ BuildRequires:  pkgconfig(libpng)
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(pixman-1)
 BuildRequires:  pkgconfig(gmock)
+BuildRequires:  pkgconfig(hal-api-tbm)
 
 %description
 Description: %{summary}
@@ -80,10 +81,11 @@ LDFLAGS+=" -lgcov"
 %endif
 
 %if %{with wayland}
-%reconfigure --prefix=%{_prefix} --with-tbm-platform=WAYLAND  --with-haltests=${HALTESTS} \
+%reconfigure --prefix=%{_prefix} --with-tbm-platform=WAYLAND  --with-haltests=${HALTESTS} --bindir=%{_bindir}/hal \
+            --with-default-dlog=yes \
             CFLAGS="${CFLAGS} -Wall -Werror" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
 %else
-%reconfigure --prefix=%{_prefix} --with-tbm-platform=X11  --with-haltests=${HALTESTS} \
+%reconfigure --prefix=%{_prefix} --with-tbm-platform=X11  --with-haltests=${HALTESTS} --bindir=%{_bindir}/hal \
             CFLAGS="${CFLAGS} -Wall -Werror" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
 %endif
 
@@ -118,7 +120,14 @@ rm -rf %{buildroot}
 %__mkdir_p %{_unitdir_user}/basic.target.wants
 ln -sf ../tbm-drm-auth-user.path %{_unitdir_user}/basic.target.wants/
 
-%post -p /sbin/ldconfig
+%post
+%if "%{HALTESTS_PACKAGE}" == "1"
+if [ -f %{_bindir}/tbm-haltests ]; then
+    rm -f %{_bindir}/tbm-haltests
+fi
+ln -s %{_bindir}/hal/tbm-haltests %{_bindir}/tbm-haltests
+%endif
+
 %postun -p /sbin/ldconfig
 rm -f %{_unitdir_user}/basic.target.wants/tbm-drm-auth-user.path
 
@@ -142,7 +151,7 @@ rm -f %{_unitdir_user}/basic.target.wants/tbm-drm-auth-user.path
 %if "%{HALTESTS_PACKAGE}" == "1"
 %files haltests
 %defattr(-,root,root,-)
-%{_bindir}/tbm-haltests
+%{_bindir}/hal/tbm-haltests
 %endif
 
 %if 0%{?gcov:1}