default_backend: install animation data files
[platform/core/uifw/libpui.git] / packaging / libpui.spec
index bf640a7..0d393ac 100644 (file)
@@ -21,6 +21,8 @@ BuildRequires:        pkgconfig(json-c)
 %{!?TZ_SYS_LIB: %global TZ_SYS_LIB /usr/lib}
 %{!?TZ_SYS_RO_SHARE: %global TZ_SYS_RO_SHARE /usr/share}
 
+%global ANIDATA_DIR %{TZ_SYS_RO_SHARE}/pui/
+
 %description
 Tizen Headless Platform User Interaction Library
 
@@ -56,11 +58,15 @@ cp %{SOURCE1001} .
 %build
 %autogen \
        --with-backend-dir=%{TZ_SYS_LIB} \
-       --with-anidata-dir=%{TZ_SYS_RO_SHARE}
+       --with-anidata-dir=%{ANIDATA_DIR}
 
 make %{?_smp_mflags}
 
 %install
+
+###### libpui default backend's animation data
+mkdir -p %{buildroot}/%{ANIDATA_DIR}/
+cp -f backends/res/* %{buildroot}/%{ANIDATA_DIR}/
 %make_install
 
 %post -n %{name} -p /sbin/ldconfig
@@ -84,6 +90,7 @@ make %{?_smp_mflags}
 %defattr(-,root,root,-)
 %license COPYING
 %{_libdir}/*default*.so*
+%{ANIDATA_DIR}/*
 
 %files samples
 %manifest %{name}.manifest