Apply -fvisibility to decrease binary size
[platform/core/uifw/ise-engine-sunpinyin.git] / packaging / ise-engine-sunpinyin.spec
index 8d3b016..e0b7ced 100755 (executable)
@@ -27,6 +27,10 @@ This package contains Chinese Pinyin engine ISE header files and static librarie
 %setup -q
 
 %build
+export CFLAGS+=" -fvisibility=hidden"
+export CXXFLAGS+=" -fvisibility=hidden -fvisibility-inlines-hidden"
+export CPPFLAGS+=" -DEXPORTED=__attribute__\(\(visibility\(\\\"default\\\"\)\)\)"
+
 ./bootstrap
 %configure  --disable-static
 make %{?jobs:-j%jobs}