Add -Werror build option
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
index 852c194..ac4a59c 100755 (executable)
@@ -69,9 +69,9 @@ Input Delegator Application for Wearable environment
 
 %build
 %if 0%{?sec_build_binary_debug_enable}
-export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
-export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
-export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
+export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
+export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
 %endif
 
 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"