change the position for exclude macro
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
index 2be6bd6..a2e2d5b 100755 (executable)
@@ -38,6 +38,13 @@ BuildRequires: pkgconfig(sqlite3)
 BuildRequires:  pkgconfig(bundle)
 %endif
 
+%if "%{?profile}" == "mobile"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%if "%{?profile}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
 
 %define _appdir                /usr/apps
 %define _app_destdir   %{_appdir}/%{name}
@@ -59,14 +66,6 @@ export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
 %endif
 
-%if "%{?tizen_profile_name}" == "mobile"
-ExcludeArch: %{arm} %ix86 x86_64
-%endif
-
-%if "%{?tizen_profile_name}" == "tv"
-ExcludeArch: %{arm} %ix86 x86_64
-%endif
-
 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"