Merge branch 'tizen_3.0' into tizen
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
index 89c9cdf..6f10afb 100755 (executable)
@@ -1,3 +1,12 @@
+# For the backward compatibility, this is to be built for
+# wearable profile or 4.0 unified building environment.
+# This cannot be built for non-wearable in conventional 3.0 build environment.
+# Note that it is not a good idea to limit building with ExcludeArch because there are new architectures being tested.
+# Use ExclusiveArch istead.
+%if "%{?profile}" == "mobile" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "common"
+ExclusiveArch:  none
+%endif
+
 Name: org.tizen.inputdelegator
 Summary: Input Delegator Application
 Version: 0.1.170316
@@ -20,6 +29,8 @@ BuildRequires: gettext-tools
 
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(capi-appfw-application)
+BuildRequires: pkgconfig(capi-appfw-app-control)
+BuildRequires: pkgconfig(capi-appfw-preference)
 BuildRequires: pkgconfig(capi-media-wav-player)
 BuildRequires: pkgconfig(capi-system-device)
 BuildRequires: pkgconfig(eina)
@@ -37,22 +48,6 @@ BuildRequires: pkgconfig(capi-media-audio-io)
 BuildRequires:  pkgconfig(bundle)
 %endif
 
-%if "%{?profile}" == "mobile"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
-%if "%{?profile}" == "tv"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
-%if "%{?profile}" == "common"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
-%if "%{?profile}" == "ivi"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
 %define _appdir                /usr/apps
 %define _app_destdir   %{_appdir}/%{name}