Change the installation path for multi-user environment.
[platform/core/uifw/e17-misc.git] / packaging / e17-misc.spec
index 70d5e4f..bfea67a 100644 (file)
@@ -23,7 +23,7 @@ cp %{SOURCE1001} .
 
 %build
 %autogen
-%configure --prefix=/opt/home/app
+%configure --prefix=/usr/share/enlightenment
 make
 
 %install
@@ -35,70 +35,78 @@ cp -a COPYING %{buildroot}/usr/share/license/%{name}
 
 %ifarch %{arm}
 # ARM build target
-%__mkdir_p %{buildroot}/opt/home/app/.e/apps
-%__cp -afr %{_arch}/opt/home/app/.e/apps/* %{buildroot}/opt/home/app/.e/apps
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/apps
+%__cp -afr %{_arch}/usr/share/enlightenment/config/apps/* %{buildroot}/usr/share/enlightenment/config/apps
 
-%__mkdir_p %{buildroot}/opt/home/app/.e/e/applications
-%__cp -afr %{_arch}/opt/home/app/.e/e/applications/* %{buildroot}/opt/home/app/.e/e/applications
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/applications
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/applications/* %{buildroot}/usr/share/enlightenment/config/e/applications
 
-%__mkdir_p %{buildroot}/opt/home/app/.e/e/backgrounds
-%__cp -afr %{_arch}/opt/home/app/.e/e/backgrounds/* %{buildroot}/opt/home/app/.e/e/backgrounds
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/backgrounds
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/backgrounds/* %{buildroot}/usr/share/enlightenment/config/e/backgrounds
 
-%__cp -afr %{_arch}/opt/home/app/.e/e/config/*.cfg %{buildroot}/opt/home/app/.e/e/config
-%__cp -afr %{_arch}/opt/home/app/.e/e/config/samsung/*.cfg %{buildroot}/opt/home/app/.e/e/config/samsung
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/config
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/config/*.cfg %{buildroot}/usr/share/enlightenment/config/e/config/
+
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/config/samsung
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/config/samsung/*.cfg %{buildroot}/usr/share/enlightenment/config/e/config/samsung/
 
 %else
 
 %if 0%{?simulator}
 # emul build target
-%__mkdir_p %{buildroot}/opt/home/app/.e/apps
-%__cp -afr emulator/opt/home/app/.e/apps/* %{buildroot}/opt/home/app/.e/apps
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/apps
+%__cp -afr emulator/usr/share/enlightenment/config/apps/* %{buildroot}/usr/share/enlightenment/config/apps
+
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/applications
+%__cp -afr emulator/usr/share/enlightenment/config/e/applications/* %{buildroot}/usr/share/enlightenment/config/e/applications
 
-%__mkdir_p %{buildroot}/opt/home/app/.e/e/applications
-%__cp -afr emulator/opt/home/app/.e/e/applications/* %{buildroot}/opt/home/app/.e/e/applications
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/backgrounds
+%__cp -afr emulator/usr/share/enlightenment/config/e/backgrounds/* %{buildroot}/usr/share/enlightenment/config/e/backgrounds
 
-%__mkdir_p %{buildroot}/opt/home/app/.e/e/backgrounds
-%__cp -afr emulator/opt/home/app/.e/e/backgrounds/* %{buildroot}/opt/home/app/.e/e/backgrounds
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/config
+%__cp -afr emulator/usr/share/enlightenment/config/e/config/*.cfg %{buildroot}/usr/share/enlightenment/config/e/config/
 
-%__cp -afr emulator/opt/home/app/.e/e/config/*.cfg %{buildroot}/opt/home/app/.e/e/config
-%__cp -afr emulator/opt/home/app/.e/e/config/samsung/*.cfg %{buildroot}/opt/home/app/.e/e/config/samsung
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/config/samsung
+%__cp -afr emulator/usr/share/enlightenment/config/e/config/samsung/*.cfg %{buildroot}/usr/share/enlightenment/config/e/config/samsung/
 
 %else
 # IA build target
-%__mkdir_p %{buildroot}/opt/home/app/.e/apps
-%__cp -afr %{_arch}/opt/home/app/.e/apps/* %{buildroot}/opt/home/app/.e/apps
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/apps
+%__cp -afr %{_arch}/usr/share/enlightenment/config/apps/* %{buildroot}/usr/share/enlightenment/config/apps
+
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/applications
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/applications/* %{buildroot}/usr/share/enlightenment/config/e/applications
 
-%__mkdir_p %{buildroot}/opt/home/app/.e/e/applications
-%__cp -afr %{_arch}/opt/home/app/.e/e/applications/* %{buildroot}/opt/home/app/.e/e/applications
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/backgrounds
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/backgrounds/* %{buildroot}/usr/share/enlightenment/config/e/backgrounds
 
-%__mkdir_p %{buildroot}/opt/home/app/.e/e/backgrounds
-%__cp -afr %{_arch}/opt/home/app/.e/e/backgrounds/* %{buildroot}/opt/home/app/.e/e/backgrounds
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/config
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/config/*.cfg %{buildroot}/usr/share/enlightenment/config/e/config/
 
-%__cp -afr %{_arch}/opt/home/app/.e/e/config/*.cfg %{buildroot}/opt/home/app/.e/e/config
-%__cp -afr %{_arch}/opt/home/app/.e/e/config/samsung/*.cfg %{buildroot}/opt/home/app/.e/e/config/samsung
+%__mkdir_p %{buildroot}/usr/share/enlightenment/config/e/config/samsung
+%__cp -afr %{_arch}/usr/share/enlightenment/config/e/config/samsung/*.cfg %{buildroot}/usr/share/enlightenment/config/e/config/samsung/
 
 %endif
 %endif
 
 %__mkdir_p %{buildroot}%{_sysconfdir}/skel
- %__cp -af %{buildroot}/opt/home/app/.e %{buildroot}%{_sysconfdir}/skel/.e
+ %__cp -af %{buildroot}/usr/share/enlightenment/config %{buildroot}%{_sysconfdir}/skel/config
 
 %pre
-if [ ! -e "home/app" ]
+if [ ! -e "/usr/share/enlightenment/config" ]
 then
-   %__mkdir_p /home/app
+   mkdir -p /usr/share/enlightenment/config
 fi
-chown 5000:5000 /home/app
-chmod 755 /home/app
+chmod 755 /usr/share/enlightenment/config
 
 %post
-# XXX comptibility with sysvinit-based images
-chown -R 5000:5000 /opt/home/app
+chmod 644 /usr/share/enlightenment/config/e/config/*.cfg
+chmod 644 /usr/share/enlightenment/config/e/config/samsung/*.cfg
 
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root,-)
-/opt/home/app/.e
+/usr/share/enlightenment/config
 /usr/share/license/%{name}
 
-%config %{_sysconfdir}/skel/.e
+%config %{_sysconfdir}/skel/config