Custom keyboard focus algorithm support
[platform/core/uifw/dali-toolkit.git] / plugins / dali-swig / Makefile.am
index 2f81c64..2ed3252 100755 (executable)
@@ -54,11 +54,16 @@ check-local: examples/dali-test.exe \
              examples/json-loader.exe \
              examples/user-alphafunction.exe \
              examples/image-view.exe \
+             examples/visuals-example.exe \
+             examples/visuals-using-custom-view.exe \
              examples/libNDalic.so examples/NDali.dll
 
 examples/%.exe: examples/%.cs
        $(MCS) -nologo -target:exe -out:$@ -reference:NDali.dll $<
 
+examples/visuals-using-custom-view.exe: examples/visuals-using-custom-view/*.cs
+       $(MCS) -nologo -target:exe -out:$@ -reference:NDali.dll $^
+
 examples/libNDalic.so: libNDalic.so
        cd examples && ln -sf ../libNDalic.so
 
@@ -78,6 +83,11 @@ $(BUILT_SOURCES): SWIG/*.i
        ./property-wrapper.rb
        ./constructor-generator.rb
 
+# have manual binding for View now, but cannot stop swig generating binding for
+# it as otherwise swig will not generate correct binding for any classes inherited
+# from it, therefore have to delete the automatic binding for View in the end
+       rm -f automatic/csharp/View.cs
+
 dist-hook: $(BUILT_SOURCES)
        mkdir -p $(distdir)/automatic/cpp
        cp ./automatic/cpp/*.cpp $(distdir)/automatic/cpp