Disable watermarking plugin
[platform/core/uifw/dali-toolkit.git] / packaging / dali-toolkit.spec
index 94098cc..bc7b054 100644 (file)
@@ -142,6 +142,11 @@ done
 ##############################
 %build
 PREFIX="/usr"
+# Disable watermarking (Annobin) plugin
+CFLAGS=$(echo $CFLAGS | sed -e 's:-fplugin=.*annobin\.so::' | sed -e 's/  */ /g')
+CXXFLAGS=$(echo $CXXFLAGS | sed -e 's:-fplugin=.*annobin\.so::' | sed -e 's/  */ /g')
+LDFLAGS=$(echo $LDFLAGS | sed -e 's:-fplugin=.*annobin\.so::' | sed -e 's/  */ /g')
+
 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
 LDFLAGS+=" -Wl,--rpath=$PREFIX/lib -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "