Merge "DALi C# binding - Avoid removal of dali-swig/manual/cpp/keyboard_focus_manager...
[platform/core/uifw/dali-toolkit.git] / packaging / dali-toolkit.spec
index fead10f..27457e1 100644 (file)
@@ -1,6 +1,6 @@
 Name:       dali-toolkit
 Summary:    The OpenGLES Canvas Core Library Toolkit
-Version:    1.1.43
+Version:    1.2.12
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-2-Clause and MIT
@@ -20,21 +20,33 @@ BuildRequires: gettext
 # Applications or dali-addon will decide which one they will use.
 BuildRequires:  dali-adaptor-devel
 
+#need libtzplatform-config for directory if tizen version is 3.x
+
+%if "%{tizen_version_major}" == "3"
+BuildRequires:  pkgconfig(libtzplatform-config)
+%endif
+
 #############################
 # profile setup
 #############################
 
+%if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
+%define profile %{tizen_profile_name}
+%endif
+
+%if "%{profile}" == "mobile"
 %define dali_toolkit_profile MOBILE
 %define dali_style_folder 720x1280
 # dali_style to be provided by build system as with dali_toolkit_profile or by passing --define 'dali_style 470x800' to the rpm build command
+%endif
 
-%if "%{?dali_style}"
-  %define dali_style_folder %{dali_style}
+%if "%{profile}" == "tv"
+%define dali_toolkit_profile TV
+%define dali_style_folder 1920x1080
 %endif
 
-# Further resource locations profiles can be provided here otherwise MOBILE will be used
-%if "%{tizen_profile_name}" == "mobile"
-  %define dali_toolkit_profile MOBILE
+%if "%{?dali_style}"
+  %define dali_style_folder %{dali_style}
 %endif
 
 %description
@@ -57,8 +69,17 @@ Application development package for the OpenGLES Canvas toolkit - headers and pa
 ##############################
 %prep
 %setup -q
+
+#Use TZ_PATH when tizen version is 3.x
+
+%if "%{tizen_version_major}" == "2"
 %define dali_data_rw_dir            /opt/usr/share/dali/
 %define dali_data_ro_dir            /usr/share/dali/
+%else
+%define dali_data_rw_dir            %TZ_SYS_SHARE/dali/
+%define dali_data_ro_dir            %TZ_SYS_RO_SHARE/dali/
+%endif
+
 %define dali_toolkit_image_files    %{dali_data_ro_dir}/toolkit/images/
 %define dali_toolkit_sound_files    %{dali_data_ro_dir}/toolkit/sounds/
 %define dali_toolkit_style_files    %{dali_data_ro_dir}/toolkit/styles/