Update gbs build makefile for node addon
[platform/core/uifw/dali-toolkit.git] / node-addon / build / tizen / CMakeLists.txt
index bd4dd2c..d418eca 100644 (file)
@@ -56,6 +56,9 @@ add_library(dali_addon SHARED
   ${PLUGING_SRC_DIR}/actors/actor-api.cpp
   ${PLUGING_SRC_DIR}/actors/layer-api.cpp
   ${PLUGING_SRC_DIR}/actors/camera-actor-api.cpp
+  ${PLUGING_SRC_DIR}/controls/control-wrapper.cpp
+  ${PLUGING_SRC_DIR}/controls/item-factory-wrapper.cpp
+  ${PLUGING_SRC_DIR}/controls/item-view-api.cpp
   ${PLUGING_SRC_DIR}/constants/constants-wrapper.cpp
   ${PLUGING_SRC_DIR}/animation/animation-api.cpp
   ${PLUGING_SRC_DIR}/animation/animation-wrapper.cpp
@@ -110,7 +113,8 @@ set_source_files_properties(${builddir}/lib.${TOOLSET}/dali.node PROPERTIES GENE
 set_target_properties(dali_addon PROPERTIES EXCLUDE_FROM_ALL "FALSE")
 
 
-SET(PKG_LIST dali
+SET(PKG_LIST dali-core
+             dali-adaptor-uv
              dali-toolkit)
 
 INCLUDE(FindPkgConfig)