Addition of new test cases
[platform/core/uifw/dali-toolkit.git] / build / tizen / docs / Makefile.am
index 8d70825..1314654 100644 (file)
@@ -5,3 +5,6 @@ all-local:
        @cat doxygen-errors.txt
        @if [ -s doxygen-errors.txt ]; then exit 1 ; fi
        @rm doxygen-errors.txt
+# Build JavaScript API documentation using yuidoc ( Yahoo JavaScript Documentation Tool )
+# We first test yuidoc exists, then change in to the dali-script-v8 docs directory and run yuidoc
+       @if [ ! `which yuidoc` = "" ]; then cd ../../../plugins/dali-script-v8/docs && yuidoc --config yuidoc.json -e ".cpp,.js,.md"  -o generated .. ../../../docs/content/shared-javascript-and-cpp-documentation/ ; fi
\ No newline at end of file