DALi Version 1.4.39
[platform/core/uifw/dali-toolkit.git] / build / tizen / configure.ac
index 24d2a9e..fe5f491 100755 (executable)
@@ -49,31 +49,6 @@ AC_ARG_ENABLE([i18n],
               [enable_i18n=$enableval],
               [enable_i18n=no])
 
-# option to build JavaScript plugin
-# configure settings and output
-# --enable-javascript        // enable_javascript = yes
-# --enable-javascript=yes    // enable_javascript = yes
-# --enable-javascript=no     // enable_javascript = no
-# --disable-javascript       // enable_javascript = no
-#  no setting                // enable_javascript = automatic ( enable if v8 present)
-AC_ARG_ENABLE([javascript],
-              [AC_HELP_STRING([--enable-javascript],
-                [Enable JavaScript plugin])],
-              [enable_javascript=$enableval],
-              [enable_javascript=automatic])
-
-# option to build C# plugin
-# configure settings and output
-# --enable-csharp        // enable_csharp = yes
-# --enable-csharp=yes    // enable_csharp = yes
-# --enable-csharp=no     // enable_csharp = no
-#  no setting            // enable_csharp = no
-AC_ARG_ENABLE([csharp],
-              [AC_HELP_STRING([--enable-csharp],
-                [Enable csharp plugin])],
-              [enable_csharp=$enableval],
-              [enable_csharp=automatic])
-
 AC_ARG_ENABLE([rename_so],
               [AC_HELP_STRING([--enable-rename-so],
                               [Specify whether so file is renamed or not])],
@@ -138,33 +113,6 @@ STYLE_DIR=$STYLE_BASE_DIR/$dali_style
 AC_SUBST(STYLE_BASE_DIR)
 AC_SUBST(STYLE_DIR)
 
-# v8 version 4+ requires c++11
-PKG_CHECK_MODULES(V8, v8 = 3.32.7, [ pkg_check_v8=yes ],  [ pkg_check_v8=no  ] )
-
-# Rules for building JavaScript plugin
-# If enable_javascript=yes and v8 installed = build javascript
-# If enable_javascript=automatic and v8 installed = build javascript
-# If enable_javascript=yes and v8 not installed = throw an error
-build_javascript_plugin=no
-if test x$enable_javascript = xyes; then
-  if test x$pkg_check_v8 = xno; then
-    [build_javascript_plugin=no]
-    AC_MSG_ERROR("V8 not found or incorrect version installed")
-    AC_MSG_NOTICE("To disable building of JavaScript plugin use --disable-javascript")
-  else
-    [build_javascript_plugin=yes]
-    AC_MSG_NOTICE(V8 library found. Building DALi JavaScript plugin)
-  fi
-fi
-if test x$enable_javascript = xautomatic && test x$pkg_check_v8 = xyes; then
-  [build_javascript_plugin=yes]
-  AC_MSG_NOTICE( V8 library found. Automatic building of JavaScript plugin. Use  use --disable-javascript to disable)
-fi
-
-
-#set a variable for the makefile to force compile the JAvaSplugin
-AM_CONDITIONAL([ENABLE_JAVASCRIPT_PLUGIN], [test x$build_javascript_plugin = xyes])
-
 # Platforms with highp shader support can use vector based text
 AM_CONDITIONAL([ENABLE_VECTOR_BASED_TEXT_RENDERING], [test x$dali_profile = xUBUNTU])
 
@@ -187,43 +135,9 @@ AC_SUBST(DOXYGEN_ROOT_DIR)
 PKG_CHECK_MODULES(DALICORE, dali-core)
 PKG_CHECK_MODULES(DALIADAPTOR, dali-adaptor)
 
-# Enable csharp plugin
-build_csharp_plugin=no
-build_ruby_flag=no
-if test x$enable_csharp = xyes; then
-  [build_csharp_plugin=yes]
-  AC_MSG_NOTICE(Building DALi csharp plugin ...)
-  AC_PATH_PROG([SWIG], [swig])
-
-  # if gbs enable, then only use swig, without ruby or mcs
-  if test "x$dali_profile" = "xUBUNTU"; then
-    [build_ruby_flag=yes]
-    AC_PATH_PROG([RUBY], [ruby])
-    AC_PATH_PROGS([MCS], [mcs gmcs gmcs2])
-    AC_MSG_NOTICE(swig ruby mcs working ...)
-  else
-    [build_ruby_flag=no]
-    AC_PATH_PROG([RUBY], [ruby])
-    #AC_PATH_PROGS([MCS], [mcs gmcs gmcs2])
-    #AC_MSG_NOTICE(swig only working ...)
-  fi
-
-  # Set varaibles for dali-toolkit
-  DALITOOLKIT_CFLAGS="-I${prefix}/include -I${prefix}/include/dali-toolkit"
-  DALITOOLKIT_LIBS="-L${prefix}/lib -ldali-toolkit -ldali-core"
-  AC_SUBST(DALITOOLKIT_CFLAGS)
-  AC_SUBST(DALITOOLKIT_LIBS)
-fi
-
-#set a variable for the makefile to force compile the csharp plugin
-AM_CONDITIONAL([ENABLE_CSHARP_PLUGIN], [test x$build_csharp_plugin = xyes])
-AM_CONDITIONAL([ENABLE_RUBY_FLAG], [test x$build_ruby_flag = xyes])
-
 AC_CONFIG_FILES([
  Makefile
  dali-toolkit/Makefile
- plugins/javascript/Makefile
- plugins/csharp/Makefile
  docs/Makefile
  docs/dali.doxy
  docs-internal/dali-internal.doxy
@@ -239,8 +153,6 @@ Configuration
   Prefix:                           $prefix
   Debug Build:                      $enable_debug
   Trace Build:                      $enable_trace
-  JavaScript support (V8 required)  $build_javascript_plugin
-  CSharp support                    $build_csharp_plugin
   Profile:                          $dali_profile
   Data Dir (Read/Write):            $dataReadWriteDir
   Data Dir (Read Only):             $dataReadOnlyDir