Removal of LITE profile
[platform/core/uifw/dali-toolkit.git] / build / tizen / configure.ac
index 454053f..a36e0a8 100644 (file)
@@ -46,25 +46,34 @@ AC_ARG_ENABLE([debug],
               [enable_debug=$enableval],
               [enable_debug=no])
 
+# option for JavaScript plugin
+AC_ARG_ENABLE(javascript,
+              [AC_HELP_STRING([--enable-javascript],
+                              [Enable JavaScript plugin])] ,
+               [enable_javascript=yes],
+               [enable_javascript=no])
+
 if test "x$enable_debug" = "xyes"; then
   DALI_TOOLKIT_CFLAGS="$DALI_TOOLKIT_CFLAGS -DDEBUG_ENABLED"
+  DALI_SCRIPTV8_CFLAGS="$DALI_TOOLKIT_CFLAGS -DDEBUG_ENABLED"
 fi
 
 if test "x$enable_debug" = "xno" -a "x$enable_exportall" = "xno"; then
   DALI_TOOLKIT_CFLAGS="$DALI_TOOLKIT_CFLAGS -fvisibility=hidden -DHIDE_DALI_INTERNALS"
+  DALI_SCRIPTV8_CFLAGS="$DALI_TOOLKIT_CFLAGS -fvisibility=hidden -DHIDE_DALI_INTERNALS"
 fi
 
+#set a variable for the makefile to conditionally compile the plugin
+AM_CONDITIONAL([ENABLE_JAVASCRIPT_PLUGIN], [test x$enable_javascript = xyes])
+
+
 # Tizen Profile options
 AC_ARG_ENABLE([profile],
-              [AC_HELP_STRING([--enable-profile=COMMON,MOBILE,LITE,WEARABLE,TV],
+              [AC_HELP_STRING([--enable-profile=COMMON,MOBILE,WEARABLE,TV],
                             [Select the variant of tizen])],
               [dali_profile=$enableval],
               [dali_profile=COMMON])
 
-# Different platforms use either the full Toolkit or the basic version
-# The basic version excludes components under dali-toolkit/optional
-AM_CONDITIONAL([TOOLKIT_BASIC_VERSION], [test x$dali_profile = xLITE])
-
 if test x$DALI_DATA_RW_DIR != x; then
   dataReadWriteDir=${DALI_DATA_RW_DIR}/
 else
@@ -80,6 +89,8 @@ fi
 AC_SUBST(dataReadWriteDir)
 AC_SUBST(dataReadOnlyDir)
 AC_SUBST(DALI_TOOLKIT_CFLAGS)
+AC_SUBST(DALI_SCRIPTV8_CFLAGS)
+AC_SUBST(DALI_SCRIPTV8_LIBS)
 
 # Specify the include directory for development headers
 #devincludepath=${includedir}/dali/internal
@@ -95,6 +106,7 @@ AC_SUBST(DOXYGEN_ROOT_DIR)
 AC_CONFIG_FILES([
  Makefile
  dali-toolkit/Makefile
+ plugins/Makefile
  dali-toolkit.pc
  docs/Makefile
  docs/dali.doxy
@@ -107,6 +119,7 @@ Configuration
 -------------
   Prefix:                           $prefix
   Debug Build:                      $enable_debug
+  JavaScript support (V8 required)  $enable_javascript
   Profile:                          $dali_profile
   Data Dir (Read/Write):            $dataReadWriteDir
   Data Dir (Read Only):             $dataReadOnlyDir