Merge "DALi Version 1.1.33" into devel/master
[platform/core/uifw/dali-toolkit.git] / build / tizen / configure.ac
index a0b795d..67156bb 100644 (file)
@@ -29,7 +29,6 @@ DALI_TOOLKIT_VERSION=dali_version
 AC_SUBST(DALI_TOOLKIT_VERSION)
 
 PKG_CHECK_MODULES(DALICORE, dali-core)
-PKG_CHECK_MODULES(DALI, dali)
 
 DALI_TOOLKIT_CFLAGS=-DPLATFORM_TIZEN
 
@@ -84,6 +83,13 @@ AC_ARG_ENABLE([profile],
               [dali_profile=$enableval],
               [dali_profile=UBUNTU])
 
+# Tizen Style Folder
+AC_ARG_WITH(style,
+              [AC_HELP_STRING([--with-style],
+                            [Select the style folder to use])],
+              [dali_style=$withval],
+              [dali_style=480x800])
+
 # Ensure valid profile selected
 if test "x$dali_profile" != "xUBUNTU" -a "x$dali_profile" != "xMOBILE" -a "x$dali_profile" != "xWEARABLE" -a "x$dali_profile" != "xTV" ; then
   AC_MSG_ERROR([$enable_profile is an invalid profile])
@@ -103,14 +109,9 @@ fi
 
 DALI_TOOLKIT_CFLAGS="$DALI_TOOLKIT_CFLAGS -DDALI_PROFILE_${dali_profile}"
 
-# Style paths
-if test "x$dali_profile" = "xUBUNTU"; then
-  STYLE_DIR=../../../dali-toolkit/styles
-fi
-
-if test "x$dali_profile" = "xMOBILE"; then
-  STYLE_DIR=../../../dali-toolkit/styles/mobile
-fi
+# Style folder
+STYLE_DIR=../../../dali-toolkit/styles
+STYLE_DIR=$STYLE_DIR/$dali_style
 
 AC_SUBST(STYLE_DIR)
 
@@ -141,6 +142,9 @@ fi
 #set a variable for the makefile to force compile the JAvaSplugin
 AM_CONDITIONAL([ENABLE_JAVASCRIPT_PLUGIN], [test x$build_javascript_plugin = xyes])
 
+# Platforms with highp shader support can use vector based text
+AM_CONDITIONAL([ENABLE_VECTOR_BASED_TEXT_RENDERING], [test x$dali_profile = xUBUNTU])
+
 AC_SUBST(dataReadWriteDir)
 AC_SUBST(dataReadOnlyDir)
 AC_SUBST(DALI_TOOLKIT_CFLAGS)
@@ -164,6 +168,7 @@ AC_CONFIG_FILES([
  dali-toolkit.pc
  docs/Makefile
  docs/dali.doxy
+ ../../automated-tests/CMakeLists.txt
 ])
 
 AC_OUTPUT
@@ -177,4 +182,7 @@ Configuration
   Profile:                          $dali_profile
   Data Dir (Read/Write):            $dataReadWriteDir
   Data Dir (Read Only):             $dataReadOnlyDir
+  Style Dir:                        $STYLE_DIR
+  Style:                            $dali_style
+  i18n:                             $enable_i18n
 "