Merge "Install default-feedback-theme.json files in styles folder" into devel/master
[platform/core/uifw/dali-toolkit.git] / build / tizen / configure.ac
index 9378eed..21e03da 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (c) 2014 Samsung Electronics Co., Ltd.
+# Copyright (c) 2016 Samsung Electronics Co., Ltd.
 #
 # Licensed under the Apache License, Version 2.0 (the "License");
 # you may not use this file except in compliance with the License.
@@ -29,7 +29,6 @@ DALI_TOOLKIT_VERSION=dali_version
 AC_SUBST(DALI_TOOLKIT_VERSION)
 
 PKG_CHECK_MODULES(DALICORE, dali-core)
-PKG_CHECK_MODULES(DALI, dali)
 
 DALI_TOOLKIT_CFLAGS=-DPLATFORM_TIZEN
 
@@ -111,9 +110,10 @@ fi
 DALI_TOOLKIT_CFLAGS="$DALI_TOOLKIT_CFLAGS -DDALI_PROFILE_${dali_profile}"
 
 # Style folder
-STYLE_DIR=../../../dali-toolkit/styles
-STYLE_DIR=$STYLE_DIR/$dali_style
+STYLE_BASE_DIR=../../../dali-toolkit/styles
+STYLE_DIR=$STYLE_BASE_DIR/$dali_style
 
+AC_SUBST(STYLE_BASE_DIR)
 AC_SUBST(STYLE_DIR)
 
 # v8 version 4+ requires c++11
@@ -143,6 +143,9 @@ fi
 #set a variable for the makefile to force compile the JAvaSplugin
 AM_CONDITIONAL([ENABLE_JAVASCRIPT_PLUGIN], [test x$build_javascript_plugin = xyes])
 
+# Platforms with highp shader support can use vector based text
+AM_CONDITIONAL([ENABLE_VECTOR_BASED_TEXT_RENDERING], [test x$dali_profile = xUBUNTU])
+
 AC_SUBST(dataReadWriteDir)
 AC_SUBST(dataReadOnlyDir)
 AC_SUBST(DALI_TOOLKIT_CFLAGS)
@@ -166,6 +169,8 @@ AC_CONFIG_FILES([
  dali-toolkit.pc
  docs/Makefile
  docs/dali.doxy
+ docs-internal/dali-internal.doxy
+ ../../automated-tests/CMakeLists.txt
 ])
 
 AC_OUTPUT
@@ -179,6 +184,7 @@ Configuration
   Profile:                          $dali_profile
   Data Dir (Read/Write):            $dataReadWriteDir
   Data Dir (Read Only):             $dataReadOnlyDir
-  Style Dir                         $STYLE_DIR
-  Style                             $dali_style
+  Style Dir:                        $STYLE_DIR
+  Style:                            $dali_style
+  i18n:                             $enable_i18n
 "