Changed minimum supported Cmake Version to allow C++17 Support
[platform/core/uifw/dali-toolkit.git] / build / tizen / CMakeLists.txt
index 22b28c3..d122fd5 100644 (file)
@@ -1,8 +1,10 @@
-CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+CMAKE_MINIMUM_REQUIRED(VERSION 3.8.2)
 CMAKE_POLICY(SET CMP0012 NEW) # Prevent dereferencing of OFF/ON as variables
 
 SET(name "dali2-toolkit")
 
+SET(CMAKE_C_STANDARD 99)
+SET(CMAKE_CXX_STANDARD 17)
 PROJECT(${name})
 SET(PKG_NAME ${name})
 
@@ -203,7 +205,6 @@ IF( WIN32 )
   ADD_COMPILE_OPTIONS( /wd4251 )                        # Ignores warning C4251: "'identifier' : class 'type' needs to have dll-interface to be used by clients of class 'type2'"
 ELSE()
   # Set up compiler flags and warnings
-  ADD_COMPILE_OPTIONS( -std=c++11 )
   ADD_COMPILE_OPTIONS( -Wno-ignored-qualifiers )
 
   # TODO: Clang is a lot more strict with warnings, we should address
@@ -344,7 +345,7 @@ IF( INSTALL_CMAKE_MODULES )
 
   # Install the pdb file.
   IF( ENABLE_DEBUG )
-    install( FILES ${CMAKE_CURRENT_BINARY_DIR}/${name}.pdb DESTINATION ${BIN_DIR} )
+    install( FILES ${CMAKE_CURRENT_BINARY_DIR}/Debug/${name}.pdb DESTINATION ${BIN_DIR} )
   ENDIF()
 ELSE()
   # Install the library so file and symlinks