[dali_1.9.25] Merge branch 'devel/master'
[platform/core/uifw/dali-toolkit.git] / build / tizen / CMakeLists.txt
index e465353..3bedbd1 100644 (file)
@@ -3,6 +3,7 @@ CMAKE_POLICY(SET CMP0012 NEW) # Prevent dereferencing of OFF/ON as variables
 
 SET(name "dali2-toolkit")
 
+SET(CMAKE_C_STANDARD 99)
 PROJECT(${name})
 SET(PKG_NAME ${name})
 
@@ -200,10 +201,11 @@ ENDIF()
 IF( WIN32 )
   ADD_COMPILE_OPTIONS( /FIdali-windows-dependencies.h ) # Adds missing definitions.
   ADD_COMPILE_OPTIONS( /vmg )                           # Avoids a 'reinterpret_cast' compile error while compiling signals and callbacks.
+  ADD_COMPILE_OPTIONS( /std:c++17 )                     # c++17 support
   ADD_COMPILE_OPTIONS( /wd4251 )                        # Ignores warning C4251: "'identifier' : class 'type' needs to have dll-interface to be used by clients of class 'type2'"
 ELSE()
   # Set up compiler flags and warnings
-  ADD_COMPILE_OPTIONS( -std=c++11 )
+  ADD_COMPILE_OPTIONS( -std=c++17 )
   ADD_COMPILE_OPTIONS( -Wno-ignored-qualifiers )
 
   # TODO: Clang is a lot more strict with warnings, we should address