Merge "Usage of CustomeView for ScrollContainer and code refactoring accordingly...
[platform/core/uifw/dali-toolkit.git] / packaging / dali-csharp-wrapper.spec
1 Name:       NDalic
2 Summary:    dali wrapper
3 Version:    1.2.15
4 Release:    1
5 Group:      uifw/graphic
6 License:    TO_BE_FILLED_IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: cmake
9 BuildRequires: swig
10 #BuildRequires: ruby
11 #BuildRequires: ruby-devel
12
13 #BuildRequires: mono-core
14 #BuildRequires: mono-compat
15 #BuildRequires: mono-data
16 #BuildRequires: mono-compiler
17 #BuildRequires: mono-wcf
18 #BuildRequires: mono-web
19
20 BuildRequires:  pkgconfig
21
22 BuildRequires: pkgconfig(glib-2.0)
23 BuildRequires: pkgconfig(dali-core)
24 BuildRequires: pkgconfig(dali-adaptor)
25 BuildRequires: pkgconfig(dali-toolkit)
26
27 BuildRequires: dali-devel
28 BuildRequires: dali-integration-devel
29 BuildRequires: dali-adaptor-devel
30 BuildRequires: dali-adaptor-integration-devel
31 BuildRequires: dali-toolkit-devel
32
33
34 %description
35 dali wrapper
36
37 %package dali-wrapper
38
39 Summary: Development dali-wrapper
40 Group: Development/Libraries/Other
41 Requires: %{name} = %{version}
42
43 %description dali-wrapper
44 Development .so for dali wrapper
45 %define daliSwigDir %{_builddir}/%{name}-%{version}/build/tizen
46 %define daliToolkitDir %{_builddir}/dali-toolkit-%{version}/build/tizen
47 %define daliPluginsDir %{_builddir}/%{name}-%{version}/build/tizen/plugins/csharp
48
49 #############################
50 # profile setup
51 #############################
52
53
54 %define dali_toolkit_profile MOBILE
55
56 %define dali_style_folder 720x1280
57 # dali_style to be provided by build system as with dali_toolkit_profile or by passing --define 'dali_style 470x800' to the rpm build command
58
59 %if "%{?dali_style}"
60   %define dali_style_folder %{dali_style}
61 %endif
62
63 # Further resource locations profiles can be provided here otherwise MOBILE will be used
64 %if "%{tizen_profile_name}" == "mobile"
65   %define dali_toolkit_profile MOBILE
66 %endif
67
68 %description
69 The OpenGLES Canvas Core Library Toolkit - a set of controls that provide
70 user interface functionality.
71
72 ##############################
73 # Preparation
74 ##############################
75 %prep
76 %setup -q
77
78 #Use TZ_PATH when tizen version is 3.x
79
80 %if "%{tizen_version_major}" == "2"
81 %define ndali_data_rw_dir            /opt/usr/share/dali/
82 %define ndali_data_ro_dir            /usr/share/dali/
83 %else
84 %define ndali_data_rw_dir            %TZ_SYS_SHARE/dali/
85 %define ndali_data_ro_dir            %TZ_SYS_RO_SHARE/dali/
86 %endif
87 ##############################
88 # Build
89 ##############################
90 %build
91 echo "----------------" %{_builddir}
92 echo "----------------" %{daliSwigDir}
93 echo "----------------" %{_libdir}
94 echo "----------------" %{daliPluginsDir}
95
96 PREFIX="/usr"
97 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections "
98 LDFLAGS+=" -Wl,--rpath=$PREFIX/lib -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
99
100 %if 0%{?enable_coverage}
101 CXXFLAGS+=" --coverage "
102 LDFLAGS+=" --coverage "
103 %endif
104
105
106 ##############################
107 # Build dali-wrap
108 ##############################
109
110 libtoolize --force
111 cd %{daliSwigDir}
112 autoreconf --install
113 NDALI_DATA_RW_DIR="%{ndali_data_rw_dir}" ; export NDALI_DATA_RW_DIR
114 NDALI_DATA_RO_DIR="%{ndali_data_ro_dir}" ; export NDALI_DATA_RO_DIR
115 %configure --enable-profile=%{dali_toolkit_profile} \
116            --with-style=%{dali_style_folder} \
117            --enable-csharp=yes \
118 %if 0%{?enable_debug}
119            --enable-debug \
120 %endif
121            --enable-i18n=yes
122 cd %{daliPluginsDir}
123 make gbs-local
124
125 ##############################
126 # Installation
127 ##############################
128 echo "----------------" %{_buildrootdir}
129 %install
130 cd "%{daliPluginsDir}"
131 make DESTDIR=%{_buildrootdir}/%{name}-%{version}-%{release}.arm/usr/lib/ gbs-install
132
133 #mv %{_builddir}/%{name}-%{version}/plugins/dali-swig/NDali.dll %{_buildrootdir}/%{name}-%{version}-%{release}.arm/usr/lib/
134
135 ##############################
136 # Post Install
137 ##############################
138 %post
139
140
141 ##############################
142 # Files in Binary Packages
143 ##############################
144 %files
145 %manifest dali-csharp-wrapper.manifest
146 %defattr(-,root,root,-)
147 %{_libdir}/lib*
148 %{_libdir}/NDali.dll
149